Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

Can't open in UML class diagram

2006-09-28
2013-04-29
  • Michael Lee
    Michael Lee
    2006-09-28

    Hi,

    I have installed Green in Eclipse 3.2/GEF 3.2/EMF 2.2.
    The "Open in UML class diagram" menu is active on a package explorer view. But it does not open any thing with this error message.

    "The chosen operation is not currently available".

    What is wrong?

    Thanks,

    Michael

     
    • Libor
      Libor
      2006-10-09

      Well, I have same problem.  I don't knpw ,how do reverse engineering as well. Is there any documentation available?
      Thanks
      Libor

       
    • B_B
      B_B
      2006-10-16

      I have the same problem as well. Do earlier releases work?
      Thanks.
      BB

       
    • Carl Alphonce
      Carl Alphonce
      2006-10-21

      Sorry to take long to respond.  The most common
      reason for this problem is that Eclipse is trying
      to use Java 1.4 or earlier to load the plug-in
      class files, which are compiled with Java 5
      (jdk 1.5).

      Yes, there is documentation in the regular Eclipse
      help system.

      Finally, when the plug-in is properly loaded with
      the 1.5 class loader, you will be able to right-click on a .java file, a .class file, a package or a project, in the *package explorer*, to show
      them in a UML class diagram.

      Please let me know how you make out, and if you
      have any further questions!

      Best Regards,
      Carl Alphonce

       
    • B_B
      B_B
      2006-10-22

      Thanks for the advice. Installed Java 5 and it works fine now.
      BB

       
    • jason
      jason
      2006-11-17

      I am experiencing the same problem and I am not sure how to correct. I have java 5 and it is the default jre for eclipse and compliance is set to 5.0 as default and yet it still gives me "The chosen operation is not currently available". How exactly do I make sure it uses java 5 to load your project class files

       
    • kingcrimson13
      kingcrimson13
      2006-11-21

      I also encountered the same problem.
      I've changed the java compiler compliance level to 5.0 under Window->Preferences->Java->Compiler.
      My default JRE in Window->Preferences->Java->JRE in java 1.5.
      I've even removed Green folders from Eclipse plugins folder, restarted Eclipse, copy Green folders to the plugins folder and restarted Eclipse again.
      I still get the message "The chosen operation is not currently available." when trying to use the plugin.

      I'll appreciate your advice.

      Thanks, David.

       
    • duffy
      duffy
      2007-01-04

      yet it still gives me "The chosen operation is not currently available".

      Like David, I have the same problem.
      I have installed Java 1.5 as default jre
      classpath variables jre_lib and jre_src are set to 1.5.0_06 direcotories
      I am trying to use 3.1.1 eclipse,
      the edu.buffalo.cse.green.* are in the plugins directory....and so are the gef 3.1.1
      org.eclipse.gef_3.1.1.jar
      I am using the green for eclipse 3.1.1
      Any other advice for this problem. David, were you able to fix your install.

       
    • Blake
      Blake
      2007-01-24

      I didn't have this problem using Eclipse 3.2.1 and GEF 3.2.1 with Green 2.5.0 RC 3

      See https://sourceforge.net/forum/message.php?msg_id=4118210

       
    • Didier
      Didier
      2007-03-28

      I faced the very same problem and here is the solution I found:

      1.  Install Java 5
      2.  Make sure to run Eclipse with Java JRE 1.5, should you have multiple versions running on your computer.  (This was my problem).

      => In order to resolve this, I created a 'start_Eclipse.bat' file and use the latter to launch Eclipse.
      => the content of this 'batch' file is:
          D:\tools\jre1.5.0_11\bin\java.exe -jar startup.jar org.eclipse.core.launcher.Main
      (Of course, adapt the path...)

      Hope this helps.

      Didier

       
    • Seonghwan Yee
      Seonghwan Yee
      2008-11-06

      I have the same error on Mac OS X 10.5
      And also I have a error on 'New' Dialog. When I select the 'Green UML Class Diagram', it makes a 'Problem Opening Wizard' message.

      -------------
      The selected wizard could not be started.
        Plug-in edu.buffalo.cse.green was unable to load class edu.buffalo.cse.green.dialogs.wizards.NewDiagramWizard.
        Bad version number in .class file
      -------------

      How can i fix it?

       
    • CyberRailGuru
      CyberRailGuru
      2008-11-07

      I have the same problem on MacOS.  I am using Java 1.5 and Eclipse 3.4.

      java version "1.5.0_16"
      Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_16-b06-284)
      Java HotSpot(TM) Client VM (build 1.5.0_16-133, mixed mode, sharing)

      Eclipse Platform

      Version: 3.4.1
      Build id: M20080911-1700

       
    • Same problem on Win32, despite Java 1.5...   (1.5.0_12, eclipse 3.4)
      Any ideas?

      Plug-in edu.buffalo.cse.green was unable to load class edu.buffalo.cse.green.action.OpenNewEditorAction.

      java.lang.UnsupportedClassVersionError: Bad version number in .class file
      at java.lang.ClassLoader.defineClass1(Native Method)
      at java.lang.ClassLoader.defineClass(ClassLoader.java:620)
      at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.defineClass(DefaultClassLoader.java:165)
      at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.defineClass(ClasspathManager.java:554)
      at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findClassImpl(ClasspathManager.java:524)
      at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findLocalClassImpl(ClasspathManager.java:455)
      [...]

      eclipse.buildId=M20080911-1700
      java.version=1.5.0_12
      java.vendor=Sun Microsystems Inc.
      BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_GB
      Command-line arguments: -os win32 -ws win32 -arch x86 -clean

       
    • Dan Padgett
      Dan Padgett
      2008-11-14

      Hi.  You are trying with the latest version of green (3.1.0 rc2)?  Could you try giving it a go with the newer Java 1.6?

       
  • Filip Mechant
    Filip Mechant
    2010-05-26

    Hi, I have a similar problem.

    Using Eclipse 3.5.2, Java 1.5.0_24 on Mac OS X 10.5.8,
    I installed Green 3.5.0 using the update site, without any problems.
    (http://www.cse.buffalo.edu/faculty/alphonce/green/)

    When I try to create a new Diagram, I get the following error:
    The selected wizard could not be started.
      Plug-in edu.buffalo.cse.green was unable to load class edu.buffalo.cse.green.dialogs.wizards.NewDiagramWizard.
      Bad version number in .class file

    Unfortunately, I am using a MacBook Pro from 2006, which is a 32-bit system. And since Apple does not provide a Java 6.0 version for 32-bit systems, your solution is not viable for me.

    Any other options?