Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

Type not supported (Error message)

2008-08-20
2013-04-29
  • Maria Papadaki
    Maria Papadaki
    2008-08-20

    Dear all,
    I have intstalled green, as described at the documentantion site
    I am using Eclipse Ganymede
    When I click at a class, I do have the option > Green UML > Add to new Class Diagram
    But then an error message appears: Type is Unsupported
    Does anyone know what is causing it?
    Any suggestions, how to resolve this?

     
    • Mike Cico
      Mike Cico
      2008-09-13

      I'm getting this also, also running Ganymede.  Is there anyone who's resolved this issue?

       
      • My Green had been working but started to give me trouble today. I right-clicked on a class in the Package Explorer and chose Green UML > Add to Last ... which yielded a "Type not supported" error dialog.

        I resolved it by installing Draw2D SDK (Runtime, Source) from http://eclipse.org/gef/downloads/

         
    • Gene Wang
      Gene Wang
      2008-09-16

      This problem is fixed with version 3.0.1.  Green is now compatible with Eclipse 3.4(Ganymede).  You can get the newest version from the downloads section.

       
  • David
    David
    2010-04-03

    I get the same "Type not supported" error dialog. i'm using green 3.4.0. But there is also an other problem! I can't create or change diagrams because my palette only contays 3 Buttons: Select, Note and Toggle Exploration Icons. Maby this problems associate with each other…
    Here a screenshot of the problem: http://img253.imageshack.us/img253/4880/greenproblem.png

    I hope you can help me.

     
  • Dan Padgett
    Dan Padgett
    2010-04-03

    Hi there.  As far as the problem with your palette, it looks like you probably installed Green, but none of the relationships packages.  Make sure to check the relationships in the update site when you install.

     
  • David
    David
    2010-04-04

    I installed all plugins that were in the green3.4.0\plugins folder and all plugins apperare in the eclipe plugin list.
    http://img231.imageshack.us/img231/732/greenplugin.png. Did i get something wrong there?(Sorry about my bad english… i'm german)
    Does anyone have some advise for me?

     
  • David
    David
    2010-04-04

    oh sorry please remove the dot at the end of the url to see the image

     
  • Dan Padgett
    Dan Padgett
    2010-04-04

    Your screenshot shows you're running version 3.1.0 - this version is pretty old.  Can you try updating to version 3.5.0 and see if the problem persists?  Thanks!

     
  • David
    David
    2010-04-04

    Thanks, that was the point. Now i can use Green!(:-) Please note that the default download from sourceforge contains not the 3.5.0 version but the 3.1.0. The lable on the green(Color) downloadbutton is "green-3.4.0" but if you download it it contains the 3.1.0 files. The 3.5.0 Version can only be found in if you click on "all files" which might be complicated for some downloaders…
    But thats not my problem…
    Thanks you very much for you fast help!