My last experience installing GRM was with 0.13.4 on windows -- went smooth as a (insert smooth thing here).  Now I'm almost full time on linux, so I went for 0.14.2.  I read the install notes, located the packages you said I needed, and installed them.  Then I tried to install GRM on Ubuntu 8.04

The first time, it required PyRTF (I interpreted the "Extra Requirements" as optional -- my bad).

The second time, it required Report Lab, which I eventually found as "python-report lab" in the Ubuntu repository.

The third time, it installed silently -- including giving me a new "optional" category in the Gnome applications menu.  But executing "gourmet" from that menu gave me nothing.  When I ran "gourmet" from a command line it told me that I had "no module named sqlalchemy".

So I hunted until I found "python-sqlalchemy", installed that, and tried for the fourth time.  It appears to work now, save for these complaints:

dee@inapan:~/GRM/gourmet-0.14.2$ gourmet
/usr/share/themes/Blubuntu/gtk-2.0/gtkrc:169: Clearlooks configuration option "progressbarstyle" is not supported and will be ignored.  ->MY PROBLEM, NOT YOURS
Connecting to file  /home/dee/.gourmet/recipes.db
/var/lib/python-support/python2.5/sqlalchemy/databases/ SADeprecationWarning: Using String type with no length for CREATE TABLE is deprecated; use the Text type explicitly
  colspec = self.preparer.format_column(column) + " " + column.type.dialect_impl(self.dialect, _for_ddl=True).get_col_spec()
/usr/lib/python2.5/site-packages/gourmet/ GtkWarning: toggleRegexp: missing action toggleRegexp
  mb = self.ui_manager.get_widget('/RecipeIndexMenuBar');
/usr/lib/python2.5/site-packages/gourmet/ GtkWarning: toggleSearchAsYouType: missing action toggleSearchAsYouType
  mb = self.ui_manager.get_widget('/RecipeIndexMenuBar');

I thought you should see these grumbles since 0.14 is under active development.

My feeling is that installation would be much easier if your explicitly checked for package/module dependencies before it does the actual install -- and certainly not *say* it's finished if it won't run.

Perhaps this problem doesn't exist in the .deb package that your Linux Installation page refers to, but I couldn't find a .deb or .rpm package in the download section.

Anyway, I'm looking forward to using GRM with its new plugins -- and to reading the code to advance my understanding of python.  Thanks for all your work -- and for continuing to add worthwhile features to this package.