installation problems - gtk

Help
ben_z
2006-05-08
2013-05-14
  • ben_z
    ben_z
    2006-05-08

    I'm running CentOS 4, and am unable to install Gourmet successfully , using either the rpm or the tarball. Either way, after installation running gourmet yields

    Traceback (most recent call last):
      File "/usr/bin/gourmet", line 33, in ?
        import gourmet.GourmetRecipeManager
      File "/usr/lib/python2.3/site-packages/gourmet/GourmetRecipeManager.py", line 4, in ?
        import prefs, prefsGui, shopgui, reccard, convertGui, fnmatch, tempfile
      File "/usr/lib/python2.3/site-packages/gourmet/shopgui.py", line 2, in ?
        import recipeManager, convert, WidgetSaver, reccard
      File "/usr/lib/python2.3/site-packages/gourmet/reccard.py", line 17, in ?
        from importers.importer import parse_range
      File "/usr/lib/python2.3/site-packages/gourmet/importers/__init__.py", line 2, in ?
        import interactive_importer
      File "/usr/lib/python2.3/site-packages/gourmet/importers/interactive_importer.py", line 14, in ?
        import imageBrowser
      File "/usr/lib/python2.3/site-packages/gourmet/importers/imageBrowser.py", line 23, in ?
        class ImageBrowser (gtk.IconView):
    AttributeError: 'module' object has no attribute 'IconView'

    Any suggestions? Is something wrong with my gtk packages?

    rpm -qa python pygtk2 gnome-python2 libglade2 metakit python-imaging
    metakit-2.4.9.3-4
    pygtk2-2.4.0-1
    python-2.3.4-14.2
    gnome-python2-2.6.0-3
    python-imaging-1.1.4-7
    libglade2-2.4.0-5

    Ben

     
    • tom
      tom
      2006-05-08

      I need to update the gtk version -- gtk 2.6 is needed for iconview. You only actually need the IconView in one small piece of gourmet at the moment - image selection from generic web imports. I should be able to put some try:/except: blocks around the relevant code and just give people with gtk 2.4 a slightly crippled but mostly fine Gourmet -- that's only worth the effort if there are still a lot of folks with gtk 2.4.x -- are there?

       
    • ben_z
      ben_z
      2006-05-09

      thanks for the quick response - look forward to trying out gourmet whenever I get my hands on gtk2.6.