pygtk version error

Help
2007-02-25
2013-05-14
  • Jeremy Elliott
    Jeremy Elliott
    2007-02-25

    Hey, I followed the instructions from the website for running Gourmet from source, downloaded all the packages listed, chose the most recent of them all *EXCEPT* GTK+, since for some reason PyGTK hasn't been update for GTK+ 2.10.7, so I downloaded pygtk-2.10.4-1.win32-py2.5.exe, then went and found GTK+ 2.10.4, downloaded it as a zipfile, got it installed and working, installed everything else, but when I run "C:\PYTHON25\PYTHON.EXE SETUP.PY INSTALL", it exits with the error "PyGTK-2.3.93 or newer is required".

    I'm running WinXP Pro with SP2 installed, does anyone have any idea what I may be able to do to correct this?  If I can get it working, I'd be more than happy to create a NSIS installer for Gourmet, I have a decent amount of experience with NSIS, but I'm not so good with programming.

    Thanks!

     
    • Jeremy Elliott
      Jeremy Elliott
      2007-02-26

      Can't seem to edit my own posts, so here's a listing of all the programs I downloaded, as displayed by the filenames:

      gourmet-0.13.3-1.tar.gz
      GTK+ 2.10.7-1.exe (before I realized that pygtk was for version 2.10.4)
      gtk+-2.10.4.zip
      PIL-1.1.6.win32-py2.5.exe
      py2exe-0.6.6.win32-py2.5.exe
      pygtk-2.10.4-1.win32-py2.5.exe
      PyRTF-0.45.tar.gz
      pysqlite-2.3.3.win32-py2.5.exe
      Python 2.5.msi
      TortoiseCVS 1.8.30.msi
      win32-dlls-py25.zip