Help>About shuts down program

Help
hcricket
2009-01-12
2013-05-14
  • hcricket
    hcricket
    2009-01-12

    Hello, I am using the Linux version of this program, running PCLOS 2007.  I click on HELP and choose ABOUT, as I wanted to see what version of Gourmet I have downloaded from our repos. 

    Unfortunately, when I do this the program shuts down.  Any thoughts on this? 

    btw, in checking the package manager, it turns out that the version of Gourmet I am running is .13.4-1. 

     
    • tom
      tom
      2009-01-13

      Can you run from the terminal and get a traceback?

       
    • hcricket
      hcricket
      2009-02-08

      Oh hi - sorry to leave this hangin.  Unfortunately, I am unable to open Gourmet at all anymore.  :(  Ever since PCLOS updated, when you open it now, it immediately shuts down.

       
      • tom
        tom
        2009-02-08

        0.14.0 had a very bad bug which destroyed the ingredients. You can send me your DB and I can attempt a rescue, but most likely it's beyond repair.

        If you'd upgraded straight from 0.13.x -> 0.14.2 or higher, you'd be fine. Unfortunately, the moment you opened your 0.13.x DB with a 0.14.0 Gourmet, it hosed your ingredients. The second time you opened, it made that hosing permanent, if I recall correctly.

        I'm very sorry for this -- I fixed this bug as soon as I found out about it, but unfortunately 0.14.0 was already out in the world as an ubuntu .deb, and I'm still working on getting ubuntu to update.

         
    • tom
      tom
      2009-02-08

      Oops -- wrong response. Ignore the above (it's for another thread).

      What is PCLOS?

       
    • hcricket
      hcricket
      2009-02-08

      My bad - PCLOS stands for PCLinuxOS, a desktop distro that runs in KDE.  I'm pretty much a complete noob, so for me, installing and maintaining updates is pretty much all about clicking buttons in the Synaptic package manager.

       
    • hcricket
      hcricket
      2009-02-08

      Clicked post too soon!

      Anyway, the devs at PCLOS just released a big update (huge) and at the end of it, I can't open Gourmet at all (it starts to open then closes immediately) rendering my Help>About question moot.

       
      • tom
        tom
        2009-02-08

        If you open a terminal and type "gourmet" to launch gourmet, you should get some useful error information that will help me determine why you're gourmet stopped working.

         
    • hcricket
      hcricket
      2009-02-08

      Here is what comes back:

      [kitchen@localhost ~]$ gourmet
      Traceback (most recent call last):
        File "/usr/bin/gourmet", line 13, in <module>
          from gourmet.OptionParser import *
      ImportError: No module named gourmet.OptionParser
      [kitchen@localhost ~]$

       
      • tom
        tom
        2009-02-08

        Sounds like wherever Gourmet is looking for it's files, they're not there. Did you install Gourmet from the tarball?

        If so, I'm guessing your upgrade changed the default version of python. When you type "python", what version shows up?  On my system, for example, it's 2.5.2. Now if I look in /usr/lib/python2.5/site-packages/, I should find gourmet there. My guess is that you have gourmet in something like /usr/lib/python2.4/site-packages and that your default python is now 2.5, or something like that.

        Re-installing gourmet should fix the issue.

         
    • tom
      tom
      2009-02-08

      Wait -- you said you used the package manager. That's stranger still then... do you see /usr/share/gourmet/OptionParser.py ?

       
    • hcricket
      hcricket
      2009-02-08

      I don't seem to have the OptionParser.py part.

       
    • hcricket
      hcricket
      2009-02-16

      Looks like the devs back at PCLOS rebuilt the package, and I am back up and running!  YAY!

       
    • hcricket
      hcricket
      2009-02-16

      Looks like the devs back at PCLOS rebuilt the package, and I am back up and running!  YAY!