Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

Fedora 12 --> 16 upgrade corrupted re...

fredrbeck
2011-12-29
2013-05-14
  • fredrbeck
    fredrbeck
    2011-12-29

    Gourmet won't start after installing the latest version - post fedora upgrade (fedora 12 -> 16).  Old recipes.db file causes errors and didn't get upgraded properly.  Removing recipes.db allows gourmet 0.15.9 to run just fine. Old DB looks to have been run with 0.13.4. (from info table in the backup DB file)

    I have tried exporting tables from the old DB using phpliteadmin, then importing via SQL and sqlite3 with no success. Old recipes appear to be imported fine, but sqlalchemy doesn't like the result. Appears like only the categories, ingredients, and recipe tables are different between the two versions.

    How can I salvage my recipes without having to enter them all again from scratch? Apparently, the divide between the two versions was just too great…

    Thanks much.