Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#85 two compile errors in a pack on X86_64 linux with GCC 4.3.0

closed-fixed
None
5
2008-04-29
2008-04-29
Anonymous
No

see the attachment

Discussion

  •  
    Attachments
  • Logged In: YES
    user_id=128624
    Originator: NO

    Regarding the first error, /usr/lib/libbz2.a is a static library which was not built with PIC code. Only PIC code may be linked into a shared library. The best solution to this is to install libbz2 as a shared library. As a quick work-around, you can add --without-bzlib to the build options so that libbz2 is not used. This has very little impact to GraphicsMagick features.

    Regarding the second error, this bug was fixed in GraphicsMagick 1.1.12, which was released yesterday. Please try using the latest release.

    Since the first problem is not a GraphicsMagick bug, and the second error has already been fixed, I am closing this issue.

     
    • assigned_to: nobody --> bfriesen
    • status: open --> closed-fixed