2009/3/7 Doug <doug_bainbridge@onetel.com>
Do you know if the place completion tool plugin is going to be updated
to be compatible with 3.1?

Done, please try the tar if it works for you:

http://www.gramps-project.org/wiki/index.php?title=3.1.x_Third-party_Plugins#Plugin_List

Benny