The bottom of your bug report is missing.

You are using an older version of GRAMPS, with direct edit on an xml file.
This is not really the recommended way. It is recommended that you create a grdb file and import the .gramps xml file into that, then do your work.

Note that GRAMPS is now version 3.0.4, consider upgrading

Benny

2009/1/23 Walter <walter@macarthurnet.com>
"User Information:
===================

reordering GRAMPS IDs


Error Details:
===================

1121977: ERROR: _Tool.py: line 271: Failed to start tool.
Traceback (most recent call last):

File "/var/tmp/gramps-2.2.9-1pclos2007-buildroot/usr/share/gramps/PluginUtils/_Tool.py",
line 267, in gui_tool

File "/var/tmp/gramps-2.2.9-1pclos2007-buildroot/usr/share/gramps/plugins/ReorderIds.py",
line 118, in __init__
   db.sprefix)

File "/var/tmp/gramps-2.2.9-1pclos2007-buildroot/usr/share/gramps/plugins/ReorderIds.py",
line 200, in reorder
   commit(obj,self.trans)

File "/var/tmp/gramps-2.2.9-1pclos2007-buildroot/usr/share/gramps/GrampsDb/_GrampsInMemDB.py",
line 289, in commit_source

File "/var/tmp/gramps-2.2.9-1pclos2007-buildroot/usr/share/gramps/GrampsDb/_GrampsInMemDB.py",
line 259, in _commit_inmem_base
KeyError: u'S01'

System Information:
===================

Python version: 2.4.3 (

------------------------------------------------------------------------------
This SF.net email is sponsored by:
SourcForge Community
SourceForge wants to tell your story.
http://p.sf.net/sfu/sf-spreadtheword
_______________________________________________
Gramps-bugs mailing list
Gramps-bugs@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/gramps-bugs