You have database error.
Did you select gedcom in the dropdown list of selectable formats instead of automatic setting?

Anyway, Gedcom import has been rewritten. As you use Ubuntu, please download the new package of GRAMPS from our website (version 3.0.4), install, and try again.
The version you are using (2.2.10) is no longer supported, so bugs there are noted, but if present in 3.0.x only solved there. Best to provide us with input of 3.0.4 import if that fails.

Greeting,
Benny

2009/1/6 Terry Bibo <tbibo@internode.on.net>
"User Information: ===================I am trying to import a gedcom
file. I have made this file, bibo.ged, in two other genealogy programs,
Brothers Keeper and Legacy. Gramps simply does not recognize the file it
calls "unknown" and says amongst other words that it will only inport
gedcomfiles.Error Details: ===================26975: ERROR: gramps.py:
line 148: Unhandled exceptionTraceback (most recent call last): File
"/usr/share/gramps/ViewManager.py", line 492, in quit
self.state.db.close() File "/usr/share/gramps/GrampsDb/_GrampsBSDDB.py",
line 1073, in close self.env.txn_checkpoint()DBRunRecoveryError:
(-30975, 'DB_RUNRECOVERY: Fatal error, run database recovery --
txn_checkpoint: failed to flush the buffer cache: DB_RUNRECOVERY: Fatal
error, run database recovery')System Information:
===================Python version: 2.5.2 (r252:60911, Jul 31 2008,
17:28:52) [GCC 4.2.3 (Ubuntu 4.2.3-2ubuntu7)] BSDDB version: 4.4.5.3
Gramps version: 2.2.10-1 LANG: en_AU.UTF-8OS: LinuxDistribution:
2.6.24-21-eeepc"


------------------------------------------------------------------------------
_______________________________________________
Gramps-bugs mailing list
Gramps-bugs@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/gramps-bugs