2008/8/8 Robert B. White <computer-bob1@mindspring.com>
Benny-

 Thank you for your reply!  I may try what you suggest.  However,
I have already tried, on 25 June 2008, installing version 3.0.1,
with the following results:
==================================================================
Starting at:
http://www.gramps-project.org

click Installation to get:
http://www.gramps-project.org/wiki/index.php?title=Installation

and follow instructions for Automatic download and install of GRAMPS"
------------------------------------------------------------------------

[(rbw)]>apt-get install gramps
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
 libsensors4 lm-sensors
Use 'apt-get autoremove' to remove them.
Recommended packages:
 graphviz python-reportlab
The following NEW packages will be installed:
 gramps
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 16.3MB of archives.
After this operation, 31.6MB of additional disk space will be used.
Get:1 http://us.archive.ubuntu.com hardy/universe gramps 2.2.10-2 [16.3MB]

Fetched 16.3MB in 1min50s (148kB/s)
Selecting previously deselected package gramps.
(Reading database ... 151507 files and directories currently installed.)
Unpacking gramps (from .../gramps_2.2.10-2_all.deb) ...
Setting up gramps (2.2.10-2) ...

------------------------------------------------------------------------
I then added graphviz python-reportlab using synaptic.
FWIW, I also removed libsensors4 lm-sensors, which are entirely unrelated
to GRAMPS.  What else will break?

Well, this installation itself broke since it installed 2.2.10-2, NOT the
expected 3.0.1!!

Download gramps_3.0.1-1_Ubuntu804.deb and attempt installation with:
dpkg -i gramps_3.0.1-1_Ubuntu804.deb

Selecting previously deselected package gramps.
(Reading database ... 151693 files and directories currently installed.)
Unpacking gramps (from gramps_3.0.1-1_Ubuntu804.deb) ...
Setting up gramps (3.0.1-1) ...

Which indeed installed 3.0.1.  This has no knowledge of any of the
existing gramps databases!

You should create a new family tree, and import your data from 2.2.x. That's it.
Obviously, you need a good working .grdb or .gramps file from 2.2.x to do this.
You find a manual on: http://gramps-project.org/wiki/index.php?title=Gramps_3.0_Wiki_Manual

Benny