Sorry but version 1.0.x is already a long time not supported.
I actually have never seen that code.

You need version 2.2, and a more recent python version.

For Mac, I can only point you to:

Otherwise you could try to write the devel or user mailing list asking for help.


2007/11/22, Chris Krenn <>:

I tried installing GRAMPS on my Mac with Fink. The code built fine. I even was walked through a set of introductory questions (email address, LDS preferences, etc.). Then a crash.

When I next tried to run, I got an error window with the following.

Any suggestions? (I used the default dependencies for fink).



Package manager version: 0.24.17
Distribution version: 0.8.1

GRAMPS has encountered an internal error.
Please copy the message below and post a bug report
at or send an
email message to

GRAMPS : 1.0.10-1
Python : 2.3.5 final
GTK : 2.6.10
PyGTK : 2.6.3
Traceback (most recent call last):
  File "/sw/share/gramps/", line 92, in ?
  File "/sw/share/gramps/", line 150, in __init__
  File "/sw/share/gramps/", line 193, in init_interface
AttributeError: 'NoneType' object has no attribute 'set_sensitive'

This email is sponsored by: Microsoft
Defy all challenges. Microsoft(R) Visual Studio 2005.
Gramps-bugs mailing list