Well, something must be causing it.
Do read: http://www.gramps-project.org/wiki/index.php?title=Recover_corrupted_grdb which is a common error made by users.
Something else is going on here though. New hard drive might have another device node on your machine, but that shouldn't matter...
Nevertheless, I would think your image path is somehow wrong. So check it carefully. Note that the tools menu has a media manager to change paths of all pictures in your database should you need it.

Benny

2007/11/20, Ralph De Witt <rdewitt001@tampabay.rr.com>:

Benny:
Thanks for the quick reply. I will try the 2.2.9 version tomorrow, It is
getting late here and I much to do tonight. I would not think this is a bad
data base, as it is a Gramps only maintained data base and worked photo's
have worked in the past. the only things that have changed are Kubuntu
version and a new machine hard drive. Back up was verified from previous
machine and was simply copied to this machine. Structure and files are all
the same and permissions are all checked and correct. But will non the less
will try to cover all bases.


--
        Yours,
        Ralph.
It said Use Windows XP or better, so I installed Kubuntu 7.10
Register Linux User 168814 ICQ #49993234 AIM & Yahoo ralphfdewitt jabber.org
ralphdewitt
GPG Public Key available at http://www.keyserver.net
Key id = 3097 3BC4
Kernel version 2.6.22-14-generic
Current Linux uptime: 2:18, days user hours  minutes.