ever got this fixed?
2.2.8 is a really ancient version. The bug here was fixed in 2.2.10 or so, so if you only can run such old version, obtain thelast bug fix release of that series, so here the 2.2 series.

As Gramps is a desktop program, using a VM on a server linux with recent desktop linux version is a better solution.


2013/7/16 Nick Ford <mrspecs@btinternet.com>
"User Information:

First time of use. could not find a new version if Gramps for Centos 6.4, due to font dependencies, but managed to install an older version.

Error Details:

27057: ERROR: gramps.py: line 148: Unhandled exception
Traceback (most recent call last):
  File "/usr/share/gramps/ViewManager.py", line 900, in new_activate
    (filename,filetype) = self.db_loader.new_file()
  File "/usr/share/gramps/DbLoader.py", line 179, in new_file
  File "/usr/share/gramps/DbLoader.py", line 465, in read_file
    _("Could not open file: %s") % filename, msg )
  File "/usr/share/gramps/QuestionDialog.py", line 174, in __init__
TypeError: GtkMessageDialog.format_secondary_markup() argument 1 must be string or None, not exceptions.AttributeError

System Information:

Python version: 2.6.6 (r266:84292, Jul 10 2013, 22:48:45) [GCC 4.4.7 20120313 (Red Hat 4.4.7-3)]
BSDDB version: 4.7.3
Gramps version: 2.2.8-0.SVNexported
LANG: en_US.utf8
OS: Linux
Distribution: 2.6.32-358.11.1.el6.x86_64

See everything from the browser to the database with AppDynamics
Get end-to-end visibility with application monitoring from AppDynamics
Isolate bottlenecks and diagnose root cause in seconds.
Start your free trial of AppDynamics Pro today!
Gramps-bugs mailing list