Please post a bug on http://www.gramps-project.org/bugs/my_view_page.php

It seems you go from version 3.3 or 3.2 to version 4.0 ? Some other people have indicated possible problems for this scenario. Exporting to .gramps and import in new version will work though. Before upgrade you normally obtained a big warning to make sure you have backups.

The error here seems to be from a gramps 3.2 database to a 3.3 database I think, with the marker field which seems to contain no data. Again, a bug on the tracker would be better, the person who rewrote markers to tags in 3.4/4.0 would be better placed to comment.

The error with db4.8_recover seems to be a bug in that program, which is an Oracle program.


Benny


2014-01-27 Fabrice DEJAIGHER <fabrice@chtiland.com>:
Hi !

I got 2 databases, the first one opens fine, but the other not.

In fact, I didn't open my tree often, and yesterday Gramps updated my first database, but got a problem when converting :

Opening in Gramps 4.0.2 (Python 3.3.3, BSDDB 6.0.0 (5, 3, 28))

When loading tree :
Schema 14 to 16

Got this message :

335034: ERROR: dbloader.py: line 107: need more than 0 values to unpack
Traceback (most recent call last):
  File "/usr/lib/python3.3/site-packages/gramps/gui/dbloader.py", line 322, in read_file
    force_python_upgrade)
  File "/usr/lib/python3.3/site-packages/gramps/gen/db/write.py", line 284, in try_
    return func(self, *args, **kwargs)
  File "/usr/lib/python3.3/site-packages/gramps/gen/db/write.py", line 730, in load
    self.gramps_upgrade(callback)
  File "/usr/lib/python3.3/site-packages/gramps/gen/db/write.py", line 2143, in gramps_upgrade
    upgrade.gramps_upgrade_15(self)
  File "/usr/lib/python3.3/site-packages/gramps/gen/db/upgrade.py", line 607, in gramps_upgrade_15
    tag_handle = convert_marker(self, marker)
  File "/usr/lib/python3.3/site-packages/gramps/gen/db/upgrade.py", line 775, in convert_marker
    marker.unserialize(marker_field)
  File "/usr/lib/python3.3/site-packages/gramps/gen/lib/grampstype.py", line 239, in unserialize
    self.__value, self.__string = data
ValueError: need more than 0 values to unpack

As repair button is not available for this tree, I tried db4.8_recover -cv (though verbose was better) but got this :

Finding last valid log LSN: file: 3 offset 120
Recovery starting from [1][28]
Erreur de segmentation
I tried with an old backup and same problem...

Any suggestion ?


--
Fabrice DEJAIGHER
( ͡° ͜ʖ ͡°)
Chtiland

------------------------------------------------------------------------------
CenturyLink Cloud: The Leader in Enterprise Cloud Services.
Learn Why More Businesses Are Choosing CenturyLink Cloud For
Critical Workloads, Development Environments & Everything In Between.
Get a Quote or Start a Free Trial Today.
http://pubads.g.doubleclick.net/gampad/clk?id=119420431&iu=/4140/ostg.clktrk
_______________________________________________
Gramps-bugs mailing list
Gramps-bugs@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/gramps-bugs