You are running Gramps version:
2.2.8-0.SVNexported 
This is a really old version. You should export to gramps xml regularly, as the grdb format will probably not be understood by current Gramps. Gramps is now version 3.3
I think there was a version 2.2.10 some years ago, which does not have this error.

Benny

2012/8/5 Rod May <rodmay@gmx.com>


"User Information: 
===================

Just upgraded to Scientific Linux 6.2. Tried to open some old files e.g. May.grdb and got the error.


Error Details: 
===================

67099: ERROR: gramps.py: line 148: Unhandled exception
Traceback (most recent call last):
  File "/usr/share/gramps/ViewManager.py", line 891, in open_activate
    (filename,filetype) = self.db_loader.open_file()
  File "/usr/share/gramps/DbLoader.py", line 114, in open_file
    self.read_file(filename,filetype)
  File "/usr/share/gramps/DbLoader.py", line 465, in read_file
    _("Could not open file: %s") % filename, msg )
  File "/usr/share/gramps/QuestionDialog.py", line 174, in __init__
    self.format_secondary_markup(msg2)
TypeError: GtkMessageDialog.format_secondary_markup() argument 1 must be string or None, not exceptions.AttributeError


System Information: 
===================

Python version: 2.6.6 (r266:84292, Jun 18 2012, 09:59:14) [GCC 4.4.6 20110731 (Red Hat 4.4.6-3)] 
BSDDB version: 4.7.3 
Gramps version: 2.2.8-0.SVNexported 
LANG: en_US.utf8
OS: Linux
Distribution: 2.6.32-279.1.1.el6.i686
"

------------------------------------------------------------------------------
Live Security Virtual Conference
Exclusive live event will cover all the ways today's security and
threat landscape has changed and how IT managers can respond. Discussions
will include endpoint security, mobile security and the latest in malware
threats. http://www.accelacomm.com/jaw/sfrnl04242012/114/50122263/
_______________________________________________
Gramps-bugs mailing list
Gramps-bugs@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/gramps-bugs