First,

Your mail via Nabble arrives 3 times for me. 2 times my name, once devel list, don't know why gmail cannot merge them. If I reply on first, I get mail back as your email in first is some nabble thing that does not receive the mail. Just to let know :-)


2013/5/17 Tim Lyons <guy.linton@gmail.com>
Benny Malengier wrote
> Some remarks
> 1. for ubuntu, it would be nice to make already clear in the table that
> the
> sourceforge deb packages can be directly installed to upgrade. Just
> download and double click the file to upgrade gramps.


Nick Hall-6 wrote
> I agree with Benny's comments.  When I go to a download page for Linux,
> I expect to find a deb, rpm and tgz file.  I don't need instructions on
> how to install from the repository.

Does double-clicking on the sourceforge deb package install all the
dependencies? Does it do the "python setup.py build" thing? Does it install
Gramps over the top of the old Gramps or does it install it somewhere else?
Does it link the newly installed Gramps to the Gramps icon on the unity
launch bar?

It should do all things needed, it is a deb after all. If it does not behave like that, then the deb package is mall formed by packager.
About Unity, that is something else. Start icon is normally added as per the freedesktop spec, don't know if Unity picks that up automatically, would hope so.

Benny

(for example, if upgrading Debian Squeeze from Gramps 3.2.3 or something
else from Gramps 2.x, I expect that there are new dependencies (if only
PyICU) - are the dependencies installed? They are installed if I use Ubuntu
Software Centre to install Gramps).

I dare say that you, Nick, don't need instructions, but surely at least some
of the Gramps wiki pages are intended for users and not developers? I did a
search for .deb and for .rpm, and couldn't find anything except under the
Debian page on creating a .deb. If we expect users to use .deb packages to
upgrade, we should be telling them how to. I will work on the pages, if
someone will answer my questions above!





Benny Malengier wrote
> 2. About gnome and kde:
> "You can use both, but Gramps fits in better with GNOME "
> Is this really true? I have never used Gnome, so can't judge, but I
> wouldn't know what I miss with KDE.

I think I will delete that bit - I don't think it is at all important.


Thanks,
Tim.



--
View this message in context: http://gramps.1791082.n4.nabble.com/4-0-tp4660187p4660242.html
Sent from the GRAMPS - Dev mailing list archive at Nabble.com.

------------------------------------------------------------------------------
AlienVault Unified Security Management (USM) platform delivers complete
security visibility with the essential security capabilities. Easily and
efficiently configure, manage, and operate all of your security controls
from a single console and one unified framework. Download a free trial.
http://p.sf.net/sfu/alienvault_d2d
_______________________________________________
Gramps-devel mailing list
Gramps-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/gramps-devel