Well,
you don't need all those dev and dbg packages to run it, but you do to build it.
I see this package includes them: https://launchpad.net/ubuntu/+source/gtk+3.0

So, you would only need libgtk-3-0, gir1.2-gtk-3.0, libgail-3-0,  libgtk-3-bin, libgtk-3-common to run them.
Somebody building gtkspell and osm-gps-map needs the dev libraries however, so if you don't want to build, you should wait for new gtkspell and osmgpsmap packages.

Benny

2012/10/9 Jérôme <romjerome@yahoo.fr>
Hi,


I am able to run trunk under my desktop, but I can have some
dependencies problems for having GtkSpell and osm-gps-map: they need
gtk+-3.0! :-\

I thought that gtk3 was already installed because trunk was running.
Minor warnings related to theme
(Gramps.py:11449): Gtk-WARNING **: Theme parsing error:
gtk-widgets.css:217:20: Not using units is deprecated. Assuming 'px'.
...
(Gramps.py:11449): Gtk-WARNING **: Theme parsing error:
button.css:151:20: Not using units is deprecated. Assuming 'px'.
...
(Gramps.py:11449): Gtk-WARNING **: Theme parsing error:
content-view.css:92:20: Not using units is deprecated. Assuming 'px'.
etc...
and the 'git.gnome.org/pygobject 3.3.2' warning, already there under
Ubuntu precise (previous installation)
/usr/local/lib/python2.7/site-packages/gi/types.py:47: Warning:
g_value_get_object: assertion `G_VALUE_HOLDS_OBJECT (value)' failed
   return info.invoke(*args, **kwargs)

$ apt-get install gtk+-3.0

Paquets suggérés :
   dh-make debian-keyring g++-multilib g++-4.6-multilib gcc-4.6-doc
   libstdc++6-4.6-dbg libgtk-3-doc libpango1.0-doc imagemagick
   libstdc++6-4.6-doc libmail-box-perl
Les NOUVEAUX paquets suivants seront installés :
   build-essential debhelper dh-apparmor dpkg-dev fakeroot g++ g++-4.6
   gir1.2-spice-client-gtk-3.0 html2text intltool-debian
   libalgorithm-diff-perl libalgorithm-diff-xs-perl libalgorithm-merge-perl
   libatk1.0-dev libdpkg-perl libgdk-pixbuf2.0-dev libgtk-3-0-dbg
   libgtk-3-dev libjavascriptcoregtk-3.0-0-dbg libjavascriptcoregtk-3.0-dev
   libmail-sendmail-perl libpango1.0-dev libspice-client-gtk-3.0-1
   libspice-client-gtk-3.0-dev libstdc++6-4.6-dev libsys-hostname-long-perl
   libwebkitgtk-3.0-0-dbg libwebkitgtk-3.0-dev libxcomposite-dev
   libxcursor-dev libxdamage-dev libxext-dev libxfixes-dev libxft-dev
   libxi-dev libxinerama-dev libxrandr-dev po-debconf x11proto-composite-dev
   x11proto-damage-dev x11proto-fixes-dev x11proto-randr-dev
   x11proto-xext-dev x11proto-xinerama-dev
0 mis à jour, 44 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre *517* Mo dans les archives.
Après cette opération, *1226* Mo d'espace disque supplémentaires seront
utilisés.

That was not planned on my system partition... :(

It seems that I will wait 'official' packages for testing GtkSpell and
osm-gps-map with Gramps.


Jérôme


------------------------------------------------------------------------------
Don't let slow site performance ruin your business. Deploy New Relic APM
Deploy New Relic app performance management and know exactly
what is happening inside your Ruby, Python, PHP, Java, and .NET app
Try New Relic at no cost today and get our sweet Data Nerd shirt too!
http://p.sf.net/sfu/newrelic-dev2dev
_______________________________________________
Gramps-devel mailing list
Gramps-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/gramps-devel