2012/10/12 jerome <romjerome@yahoo.fr>
> " '/usr/local/lib/libosmgpsmap.so.2.0.1' is the compiled one, used for testing trunk. I will remove it and will make a new test."

Gramps 3.4.1 is back (runs fine) after removing '/usr/local/lib/libosmgpsmap.so.2.0.1'!


Serge, is it possible your version of osmgpsmap loads gtk from a different typelib? That would cause the error of GtkWidget being defined a second time.
That is, in /usr/lib/girepository-1.0/ different versions of Gtk can be present, correct one must be loaded. Normally the latest version is taken automatically though:

http://developer.gnome.org/gi/unstable/gi-girepository.html#g-irepository-require

Otherwise an ambiguity of PYTHONPATH or load of typelib of a non custom directory.

Benny
 

--- En date de : Ven 12.10.12, jerome <romjerome@yahoo.fr> a écrit :

> De: jerome <romjerome@yahoo.fr>
> Objet: Re: [Gramps-devel] Get Gramps 3.4 back? (was Gtk3 problems with ValidatedComboEntry on ubuntu 12.10)
> À: "Serge Noiraud" <Serge.Noiraud@free.fr>
> Cc: "Gramps developers" <gramps-devel@lists.sourceforge.net>
> Date: Vendredi 12 octobre 2012, 9h44
> Note, I get some additionnal
> informations...
>
> "The crashed program seems to use third-party or local
> libraries:
>
> /usr/local/lib/libosmgpsmap.so.2.0.1
>
> It is highly recommended to check if the problem persists
> without those first.
>
> Do you want to continue the report process anyway?"
>
> : yes
>
> "Le problème ne peut être signalé :
>
> Ce paquet n'est pas officiellement pris en charge par
> elementary. Veuillez désinstaller tout paquet tiers et
> réessayer."
>
> :(
>
> '/usr/local/lib/libosmgpsmap.so.2.0.1' is the compiled one,
> used for testing trunk. I will remove it and will make a new
> test.
>
>
> Jérôme
>
>
>
> --- En date de : Jeu 11.10.12, Serge Noiraud <Serge.Noiraud@free.fr>
> a écrit :
>
> > De: Serge Noiraud <Serge.Noiraud@free.fr>
> > Objet: Re: Get Gramps 3.4 back? (was Gtk3 problems with
> ValidatedComboEntry on ubuntu 12.10)
> > À: "jerome" <romjerome@yahoo.fr>
> > Cc: "Gramps developers" <gramps-devel@lists.sourceforge.net>
> > Date: Jeudi 11 octobre 2012, 19h50
> > Le 11/10/2012 10:59, jerome a écrit
> > :
> > > I made a bug report
> > > https://bugs.launchpad.net/elementaryos/+bug/1065414
> > I have the same problem on ubuntu too !
> > I installed the gramps package from the repository and
> it
> > core dumps.
> >
> > I think there is a bohrr effect somewhere ...
> >
> > >
> > > I suppose that I made something wrong by trying to
> test
> > 'trunk'...
> > > I see that this is related to
> > /usr/lib/python2.7/dist-packages/gobject/_gobject.so
> > >
> > > But how to get back a working Gramps 3.4.x???
> > >
> > > It was running fine, last week.
> > > I should have the correct libs (gtk2, pygtk, etc
> ...).
> > >
> > > It just seems that I made something wrong for
> properly
> > switching between versions on the same installation!
> :(
> > >
> > > Any idea?
> > >
> > > Thank you!
> > > Jérôme
> > >
> > > --- En date de : Jeu 11.10.12, jerome <romjerome@yahoo.fr>
> > a écrit :
> > >
> > >> De: jerome <romjerome@yahoo.fr>
> > >> Objet: [Gramps-devel] Re : Gtk3 problems with
> > ValidatedComboEntry on ubuntu 12.10
> > >> À: "Gramps developers" <gramps-devel@lists.sourceforge.net>,
> > "Serge Noiraud" <Serge.Noiraud@free.fr>
> > >> Date: Jeudi 11 octobre 2012, 10h24
> > >> Hi,
> > >>
> > >>
> > >> I also get problems since update (precise
> based),
> > but on
> > >> 3.4.x branch!
> > >>
> > >> <string>:31: Warning: cannot register
> > existing type
> > >> `GtkWidget'
> > >> <string>:31: Warning: cannot add class
> > private field
> > >> to invalid type '<invalid>'
> > >> <string>:31: Warning:
> > g_type_add_interface_static:
> > >> assertion `G_TYPE_IS_INSTANTIATABLE
> > (instance_type)' failed
> > >> <string>:31: Warning: cannot register
> > existing type
> > >> `GtkBuildable'
> > >> <string>:31: Warning:
> > >> g_type_interface_add_prerequisite: assertion
> > >> `G_TYPE_IS_INTERFACE (interface_type)' failed
> > >> <string>:31: Warning:
> g_once_init_leave:
> > assertion
> > >> `result != 0' failed
> > >> <string>:31: Warning:
> > g_type_register_static:
> > >> assertion `parent_type > 0' failed
> > >> <string>:31: Warning: g_type_get_qdata:
> > assertion
> > >> `node != NULL' failed
> > >> Erreur de segmentation (core dumped)
> > >>
> > >> kernel: [ 2542.377297] switchboard[4574]:
> segfault
> > at 0 ip
> > >> 009759ee sp bf9593d0 error 4 in
> > >> libgtk-3.so.0.517.0[8fe000+518000]
> > >> kernel: [ 2660.438120] python[4678]: segfault
> at
> > bf49afd4 ip
> > >> 00301b66 sp bf49afd0 error 6 in
> > libc-2.15.so[2bf000+1a3000]
> > >> kernel: [ 3230.567319] python[8051]: segfault
> at
> > bf79cf74 ip
> > >> 00516b66 sp bf79cf70 error 6 in
> > libc-2.15.so[4d4000+1a3000]
> > >>
> > >>
> _______________________________________________
> > >> Gramps-devel mailing list
> > >> Gramps-devel@lists.sourceforge.net
> > >> https://lists.sourceforge.net/lists/listinfo/gramps-devel
> > >>
> > >
> >
> >
>
>
> ------------------------------------------------------------------------------
> Don't let slow site performance ruin your business. Deploy
> New Relic APM
> Deploy New Relic app performance management and know
> exactly
> what is happening inside your Ruby, Python, PHP, Java, and
> .NET app
> Try New Relic at no cost today and get our sweet Data Nerd
> shirt too!
> http://p.sf.net/sfu/newrelic-dev2dev
> _______________________________________________
> Gramps-devel mailing list
> Gramps-devel@lists.sourceforge.net
> https://lists.sourceforge.net/lists/listinfo/gramps-devel
>

------------------------------------------------------------------------------
Don't let slow site performance ruin your business. Deploy New Relic APM
Deploy New Relic app performance management and know exactly
what is happening inside your Ruby, Python, PHP, Java, and .NET app
Try New Relic at no cost today and get our sweet Data Nerd shirt too!
http://p.sf.net/sfu/newrelic-dev2dev
_______________________________________________
Gramps-devel mailing list
Gramps-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/gramps-devel