Ok I think I figured what was going on.  I'm totally new to gramps and just created a Family Tree. I wanted it saved in a specific directory (one that has regular backups) but I couldn't figure out how to move a Family Tree. First I tried changing the "Family Tree Database path" setting but that didn't seem to do anything. So then I exported as a Gramps XML (since I had no media) to the desired directory. When I clicked on the .gramps file in Finder, it was opening Gramps but loading the original Family Tree (I had open last used tree checked). So I was never really editing or saving the tree in the new location. The reason the Family Tree Manager was empty was because it only shows what is in the Family Tree Database path, and I hadn't saved any trees to the new location yet.

I was able to "move" my tree by creating an empty tree in the new location, and importing a grampsdb that I exported from the old one. After that I could archive. Not sure if that's the recommended way of moving a tree but it seems to have worked.

A lot of this was very confusing. Here are a few suggestions:
- Add a wiki page for moving trees. I'm still not sure if I did it correctly because it seems there are more settings for where media gets stored.
- Family Tree manager should show what directory it is currently browsing. It didn't make sense to me why I had a tree open but the manager showed no trees. Ideally I would be able to change the directory from there as well.

Thanks,
Mitch

Mitch


On Thu, Nov 1, 2012 at 3:54 PM, John Ralls <jralls@ceridwen.us> wrote:

On Nov 1, 2012, at 10:19 AM, Mitchell Slep <mitch@moomoobloo.com> wrote:

> I opened a family tree by clicking on its .gramps file. The tree opens properly and I am able to edit, save changes, etc. However, when I click on the "Family Trees" button or select "Manage Family Trees" from the menu, the resulting dialog box is empty.
>
> This is preventing me from archiving my tree.
>
> I'm on Gramps 3.4.2-1 OS:Darwin.

Gramps isn't supposed to open .gramps files directly, so you must have a modified version. Where did you get it?

A .gramps file is normally an exported xml file, and the way to load it is to start gramps, create a new Family Tree, open the new tree, and import the .gramps file. Once you've done that you'll create a proper grampsdb which you'll be able to archive.

However, your modified Gramps might be making some sort of bundle out of a normal gramps database (which is a directory, not a single file). If you control-click on the .gramps file in Finder, is "Show Package Contents" one of the items on the menu?

Regards,
John Ralls