Sandra,

The problem is that you use the binary format to upgrade, and this is very problematic for different reasons.

How to continue is in
http://gramps-project.org/wiki/index.php?title=Recover_corrupted_grdb

So, you have a grdb file, that means the previous version of gramps was 2.0.x or 2.2.x.
Do you still have the database environment:
~/.gramps/grampsdb
If so, backup this and the grdb by taking a copy of it.

Then, try the dump/load tool as explained in http://gramps-project.org/wiki/index.php?title=Recover_corrupted_grdb#Version_2.2.x:_GRDB_corruption

There are several possibilities:
1/ dump/load fixes it and the created file is in a good state
2/ still problems, and you have the environment: then we copy the environment in an old linux distro, and open the grdb again with the previous version of Gramps, and do export to xml.
3/ we find another solution

You should be able to try 1/ yourself. If problems, mail me back.

Benny

2010/8/23 Sandra Carral <s_carral@hotmail.com>
Sometime last year I created a family tree with some version of gramps I had back then in my computer. We did some upgrades in it, and now I have ubuntu 10.04 with gramps version 3.2.3-1. When I type gramps MyFamily.grdb in the command window I get the following message:

gramps MyFamily.grdb
Trying to open: MyFamily.grdb ...
Warning: spelling checker disabled; install pyenchant/python-enchant to enable.
Starting Import, Importing data...
Traceback (most recent call last):
  File "/usr/share/gramps/plugins/import/ImportGrdb.py", line 2671, in importData
    other_database.load(new_filename, callback)
  File "/usr/share/gramps/plugins/import/ImportGrdb.py", line 394, in load
    self.__close_early()
  File "/usr/share/gramps/plugins/import/ImportGrdb.py", line 1106, in __close_early
    raise DbVersionError()
DbVersionError: The database version is not supported by this version of Gramps.
Please upgrade to the corresponding version or use XML for porting data between different database versions.

I don't have the older version of gramps anymore. How can I recover my data? Is it possible to downgrade gramps to do an XML export? Where would I get the files from? If that's not possible, what other options would I have?

Thanks!

------------------------------------------------------------------------------
Sell apps to millions through the Intel(R) Atom(Tm) Developer Program
Be part of this innovative community and reach millions of netbook users
worldwide. Take advantage of special opportunities to increase revenue and
speed time-to-market. Join now, and jumpstart your future.
http://p.sf.net/sfu/intel-atom-d2d
_______________________________________________
Gramps-bugs mailing list
Gramps-bugs@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/gramps-bugs