2010/5/22 Alvin Larson <alvinlarson@comcast.net>
Stéphane Charette wrote:
> 2010/4/22 Alvin Larson <alvinlarson@comcast.net>
>
>> Stéphane:
>>
>> I am still using Ubuntu 8.04 (sorry about that) and there are only new versions
>> of GRAMPS for Ubuntu 9.0 and 10.0.  Do I need to upgrade Ubuntu to use the
>> new GRAMPS or will there be a version for Ubuntu 8.04?  Or, will the
>> gramps-3.2.1.tar.gz version work on Ubuntu 8.04?
>>
>
> I cannot get the .deb to build on Ubuntu 8.04 anymore.
>
> As you wrote, there are 2 obvious options:
>
> 1)  The first solution is to upgrade from 8.xx to something newer.
>
> 2)  Another solution is to install from source using the .tar.gz file.
>  We do have a wiki page that describes how to do that, but considering
> you're still on 8.04, I'm guessing extracting .tar.gz files,
> compiling, and installing/running from source isn't something you know
> how to do.  The wiki page that describes how to run from source is
> here:  http://www.gramps-project.org/wiki/index.php?title=Running_a_development_version_of_Gramps
>
> Another possible option you haven't stated is we have a volunteer that
> wants to help maintain the .deb files for the older releases.  The
> problem we have today is the debian files have changed and no longer
> work for anything older than 9.04.  If someone wants to take on the
> task of creating the Ubuntu 7.xx and 8.xx .deb files then you'd have
> what you need.
>
> Stéphane
>
>
Stéphane

I installed Kubuntu 10.04 on a second hard disk and it unusable for me.
Samba doesn't work, it doesn't recognize my old parallel port printer,
the driver on my new HP 8009 printer is messed up, there is no place to
set a fixed ip address, and other things.

I tried the second option, i.e., run from the source, using the web page
from above, on my Kubuntu 8.04, but that didn't go very well either.
Here is the error message I got when I tried to run "python src/gramps.py":

arl@cledus-b:~/gramps/trunk$ python src/gramps.py

Locale dir does not exist at/usr/local/share/locale/share/locale
Running ./configure --prefix=YourPrefixDir might fix the problem
Importing old key file 'keys.ini'...
WARNING: ignoring old key 'preferences.geoview'
WARNING: ignoring old key 'interface.data-views'
Done importing old key file 'keys.ini'
708: ERROR: grampsgui.py: line 303: Gramps failed to start.
Traceback (most recent call last):
 File "/home/arl/gramps/trunk/src/gui/grampsgui.py", line 283, in
__startgramps
   Gramps(argparser)
 File "/home/arl/gramps/trunk/src/gui/grampsgui.py", line 203, in __init__
   from viewmanager import ViewManager
 File "/home/arl/gramps/trunk/src/gui/viewmanager.py", line 62, in <module>
   from gui.plug import tool
 File "/home/arl/gramps/trunk/src/gui/plug/__init__.py", line 35, in
<module>
   import _windows as PluginWindows
 File "/home/arl/gramps/trunk/src/gui/plug/_windows.py", line 56, in
<module>
   from gui.editors import EditPerson
 File "/home/arl/gramps/trunk/src/gui/editors/__init__.py", line 70
    except Exception as msg:
                      ^
 SyntaxError: invalid syntax

This cannot work because trunk is the code that will be released in 2011 and aims for python 2.6. You don't  have that in 8.04.
Moreover that code is unstable.
You must obtain the branch 32 code, that will work fine on ubuntu 8.04.


Other things I tried:

1) Adding node locale to /usr/local/share/

2) Running ./configure --prefix=YourPrefixDir , but didn't know what to
put in for YourPrefixDir

3)  Running update:
         arl@cledus-b:~/gramps/trunk$ svn update
         At revision 15448.

I was thinking of switching from Ubuntu to Debian, but then I would
always be running an old version of Gramps because Debian 5.04 (stable
version) uses even older applications than Kubuntu 8.04 so Gramps 3.2.3
most likely won't run on it either.  I tried out the Debian 5.04 live
DVD.  I was going to try  the "testing" version, but it wasn't obvious
where to get it from.

You can install packages from debian testing in debian stable, provided they are low on dependencies. I don't know about Gramps, it might pull in some other things from testing, one would have to try to know. As 3.2 works on ubuntu 8.04, it should work on testing too.
About your kubuntu problems, post bugs in launchpad, they need to know it to be able to fix it.

Benny

Thank you,

Al Larson





------------------------------------------------------------------------------

_______________________________________________
Gramps-users mailing list
Gramps-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/gramps-users