Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

#264 gpasm 1.1.0 core dumps using mixed CONFIG __CONFIG

None
closed
Borut Ražem
None
1
2013-05-09
2013-05-04
Roy Rankin
No

when running gpasm 1.1.0 with the attached file, gpasm core dumps after displaying the following:
Starting program: /usr/bin/gpasm -c stack.asm
stack.asm:16:Error[177] You cannot mix CONFIG and CONFIG directives.
stack.asm:17:Error[177] You cannot mix CONFIG and
CONFIG directives.
gpasm: coff.c:100: _update_reloc_ptr: Assertion `0' failed.

1 Attachments

Related

Bugs: #264

Discussion

  • Borut Ražem
    Borut Ražem
    2013-05-04

    Roy,

    I tried it with the svn HEAD and there is no assertion failure: the config handling was heavily reworked in gpasm 1.2.0.

    Can you please try it too?

    Borut

     
  • Roy Rankin
    Roy Rankin
    2013-05-04

    Borat,

    When I run the gpsim p18f/ extended_instructions.asm regression test
    assembled and linked by gputils-1.2.0RC1,
     I get the message from gpsim of ".cod range error" and the test
    fails. Everything runs OK if I user gputils-1.1.0.
    I am not sure which program is to blame on this.

    I am using the current SVN version of gpsim which I checked in a few
    minutes ago.

    Could you take a look and see what you think.

    Roy

    ----- Original Message -----
    From: "[gputils:bugs]"
    To:"[gputils:bugs]"
    Cc:
    Sent:Sat, 04 May 2013 09:05:54 +0000
    Subject:[gputils:bugs] #264 gpasm 1.1.0 core dumps using mixed CONFIG
    __CONFIG

    Roy,
    
    I tried it with the svn HEAD and there is no assertion failure: the
    

    config handling was heavily reworked in gpasm 1.2.0.

    Can you please try it too?
    
    Borut
    

     [BUGS:#264] [1] GPASM 1.1.0 CORE DUMPS USING MIXED CONFIG __CONFIG
    
    STATUS: closed
    

    CREATED: Sat May 04, 2013 01:11 AM UTC by Roy Rankin
    LAST UPDATED: Sat May 04, 2013 01:11 AM UTC
    OWNER: Borut Ražem

    when running gpasm 1.1.0 with the attached file, gpasm core dumps
    

    after displaying the following:
    Starting program: /usr/bin/gpasm -c stack.asm
    stack.asm:16:Error[177] You cannot mix CONFIG and CONFIG directives.
    stack.asm:17:Error[177] You cannot mix CONFIG and CONFIG directives.
    gpasm: coff.c:100: _update_reloc_ptr: Assertion `0' failed.


    Sent from sourceforge.net because you indicated interest in
    

    https://sourceforge.net/p/gputils/bugs/264/ [2]

    To unsubscribe from further messages, please visit
    

    https://sourceforge.net/auth/subscriptions/ [3]

    [1]
    http://webmail.iinet.net.au/HTTP://SOURCEFORGE.NET/P/GPUTILS/BUGS/264/
    [2] https://sourceforge.net/p/gputils/bugs/264/
    [3] https://sourceforge.net/auth/subscriptions/

     
  • Borut Ražem
    Borut Ražem
    2013-05-04

    I'll take a look.

    Borut

    On 04. 05. 2013 14:28, Roy Rankin wrote:

    Borat,

    When I run the gpsim p18f/ extended_instructions.asm regression test
    assembled and linked by gputils-1.2.0RC1,
    I get the message from gpsim of ".cod range error" and the test
    fails. Everything runs OK if I user gputils-1.1.0.
    I am not sure which program is to blame on this.

    I am using the current SVN version of gpsim which I checked in a few
    minutes ago.

    Could you take a look and see what you think.

    Roy

    ----- Original Message -----
    From: "[gputils:bugs]"
    To:"[gputils:bugs]"
    Cc:
    Sent:Sat, 04 May 2013 09:05:54 +0000
    Subject:[gputils:bugs] #264 gpasm 1.1.0 core dumps using mixed CONFIG
    __CONFIG

    Roy,

    I tried it with the svn HEAD and there is no assertion failure: the

    config handling was heavily reworked in gpasm 1.2.0.

    Can you please try it too?

    Borut

    [BUGS:#264] [1] GPASM 1.1.0CORE DUMPS USING MIXED CONFIG __CONFIG

    STATUS: closed

    CREATED: Sat May 04, 2013 01:11 AM UTC by Roy Rankin
    LAST UPDATED: Sat May 04, 2013 01:11 AM UTC
    OWNER: Borut Ražem

    when running gpasm 1.1.0with the attached file, gpasm core dumps

    after displaying the following:
    Starting program: /usr/bin/gpasm -c stack.asm
    stack.asm:16:Error[177] You cannot mix CONFIG and CONFIG directives.
    stack.asm:17:Error[177] You cannot mix CONFIG and CONFIG directives.
    gpasm: coff.c:100: _update_reloc_ptr: Assertion `0' failed.


    Sent from sourceforge.net because you indicated interest in

    https://sourceforge.net/p/gputils/bugs/264/ [2]

    To unsubscribe from further messages, please visit

    https://sourceforge.net/auth/subscriptions/ [3]

    Links:
    

    [1]
    http://webmail.iinet.net.au/HTTP://SOURCEFORGE.NET/P/GPUTILS/BUGS/264/
    [2] https://sourceforge.net/p/gputils/bugs/264/
    [3] https://sourceforge.net/auth/subscriptions/


    [bugs:#264] http://sourceforge.net/p/gputils/bugs/264/ gpasm 1.1.0
    core dumps using mixed CONFIG __CONFIG

    Status: closed
    Created: Sat May 04, 2013 01:11 AM UTC by Roy Rankin
    Last Updated: Sat May 04, 2013 09:05 AM UTC
    Owner: Borut Ražem

    when running gpasm 1.1.0 with the attached file, gpasm core dumps
    after displaying the following:
    Starting program: /usr/bin/gpasm -c stack.asm
    stack.asm:16:Error[177] You cannot mix CONFIG and CONFIG directives.
    stack.asm:17:Error[177] You cannot mix CONFIG and
    CONFIG directives.
    gpasm: coff.c:100: _update_reloc_ptr: Assertion `0' failed.


    Sent from sourceforge.net because you indicated interest in
    https://sourceforge.net/p/gputils/bugs/264/

    To unsubscribe from further messages, please visit
    https://sourceforge.net/auth/subscriptions/

     

    Related

    Bugs: #264

  • Borut Ražem
    Borut Ražem
    2013-05-04

    Problem is that the .cod file now includes also the config locations, which is wrong :-(

    I'm working on it...

    Borut

     
    Last edit: Borut Ražem 2013-05-04
  • Borut Ražem
    Borut Ražem
    2013-05-09

    My previous comment was wrong: config locations should be included in the cod file. The problem was that they were not included correctly.

    Fixed in revision #970.

    Borut

     


Anonymous


Cancel   Add attachments