#6 Link libgpsimcli with libreadline

closed-accepted
nobody
None
5
2006-07-02
2006-04-15
No

Currently libgpsimcli uses functions from readline
library but doesn't link against it, leaving to the
final binary to link against it. This not only is
problematic as the final binary has to know that, but
it also breaks when using --as-needed flag.

For an introduction to --as-needed usage and related
problems, see
http://www.gentoo.org/proj/en/qa/asneeded.xml .

The attached patch fixes linking of libgpsimcli and
allows to link against it with --as-needed.

HTH,
Diego "Flameeyes" Pettenò <flameeyes@gentoo.org>

Discussion


Anonymous


Cancel   Add attachments