Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

Problem with "package req udp"

2007-11-16
2013-06-04
  • When run with "wish8.4 gpsfeed+.tcl" I get the unexpected result:

    Error in startup script: can't find package udp
        while executing
    "package req udp"
        (file "./gpsfeed+.tcl" line 738)

    I tried looking for udp modules, but cant seem to find any. Some pointers/help would be grately appreciated.

     
    • dzach
      dzach
      2007-11-16

    • More reading and searching got me to the same answer. I downloaded tcludp from Sourceforge. To make tcludp I had to 'apt-get install tcl8.4-dev' (I'm using Kubuntu). I needed to specify the --with-tcl argument for configure (./configure --with-tcl=/usr/lib/tcl8.4/). I then used standard make to compile, and checkinstall to install (checkinstall -D make install).

      Running gpsfeed+.tcl (./gpsfeed+.tcl) provided me with the expected application.

      Thank you for the help.

       

  • Anonymous
    2012-02-18

    sudo apt-get install libudp-tcl