#43 Ubuntu Jaunty and Karmic dependency errors

gpsdrive-2.10pre7
closed-out-of-date
nobody
5
2012-05-19
2009-11-18
Anonymous
No

Although there are jaunty and karmic packages in http://www.gpsdrive.de/ubuntu/pool/karmic/ for the ubuntu repository, there us no karmic directory in http://www.gpsdrive.de/ubuntu/dists/ (or jaunty directory either) so it is not possible to use the Jaunty of Karmic repos for gps drive to get the latest from GpsDrive.

Discussion

  • Jörg Ostertag
    Jörg Ostertag
    2009-11-20

    Please recheck; I added some new files to the dist directories.

     

  • Anonymous
    2009-11-22

    Ok this fixed adding the repository in karmic, however I still cannot download gpsdrive from this repo because of dependency errors, giving the following error:

    ******@******:~$ sudo apt-get install gpsdrive
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies.
    gpsdrive: Depends: libmapnik (> 0.5.0-1) but it is not installable or
    libmapnik0.5 but it is not installable
    Recommends: gpsdrive-data-maps (> 2322) but it is not going to be installed
    Recommends: openstreetmap-utils (> 8290) but it is not going to be installed or
    gpsdrive-utils (> 2.10svn2299) but it is not going to be installed
    Recommends: mapnik-plugins but it is not installable
    Recommends: openstreetmap-mapnik-data but it is not going to be installed
    E: Broken packages

    Searching for the packages mentioned in the error this is what I found:

    libmapnik: the version in the karmic repos is libmapnik0.6 , gpsdrive doesn't seem to like this
    gpsdrive-data-maps: the version available is 2.10svn2470 , gpsdrive wants 2322, maybe the package needs appending 2.10svn to its dependency for data-maps...
    gpsdrive-utils: I can't work out the problem with this one, gpsdrive wants >2.10svn2299, the version in the package manager is 2.10svn2525, so this one shouldn't be a problem =S
    mapnik-plugins: this isn't in the karmic package manager
    openstreetmap-mapnik-data: this one is in the repository so I don't know why it wont install it,

    Hope this info helps resolve the issues.

     
  • Jörg Ostertag
    Jörg Ostertag
    2009-11-23

    • summary: Ubuntu Jaunty and Karmic repos not useable --> Ubuntu Jaunty and Karmic dependency errors
     
  • Glucose Grin
    Glucose Grin
    2010-01-21

    I'm getting the same error. When I manually install the missing dependencies, it will install, but errors on run now, so my fix dosn't fix anything...
    Connection to Speech Dispatcher established.
    Connection to GPS Daemon on 127.0.0.1:2947 established.
    DB: Using waypoints from local user file.
    DB: Using street data from Mapnik database.
    Read 528 POI-Types from geoinfo.db
    Segmentation fault

     
  • Hamish B
    Hamish B
    2012-05-19

    • status: open --> closed-out-of-date
     
  • Hamish B
    Hamish B
    2012-05-19

    try a newer : )

    Hamish