--- a/sources/trunk/autogen.sh
+++ b/sources/trunk/autogen.sh
@@ -5,15 +5,10 @@
 test -z "$srcdir" && srcdir=.
 
 PKG_NAME="gparted"
-REQUIRED_AUTOMAKE_VERSION=1.7
 
 which gnome-autogen.sh || {
     echo "You need to install gnome-common from the GNOME CVS"
     exit 1
 }
 
-#i needed to put this one here on order to fix an weird depcomp error
-aclocal
-
-
-USE_GNOME2_MACROS=1 . gnome-autogen.sh
+REQUIRED_AUTOMAKE_VERSION=1.9 USE_GNOME2_MACROS=1 . gnome-autogen.sh