#77 Tray Icon

open
nobody
None
5
2011-01-04
2011-01-03
milkdudjenkins
No

My tray icon doesn't appear when X starts at my primary location. However, when I was at an alternative location, it mysteriously popped up on its own. I thought the problem might have been with OpenDNS's servers, but that wasn't it (disabled it on my router). Is there a verbose setting for GS so that I can see what's wrong from the command line? Both log files under the /tmp/googsystra-XXXXX are empty.

Thanks!

Discussion

  • Jim Duchek
    Jim Duchek
    2011-01-03

    Its likely related to the network startup. There's an... issue with the networking in glibc where things can go to hell if an interface starts up after googsystray. I've got an idea for a workaround, but for right now, if you see it, you'll just need to start googsystray after the network comes up.

     
  • milkdudjenkins
    milkdudjenkins
    2011-01-04

    Jim, I don't think it's GS or glibc. Either it's my install of python or the damnable DSL modem/wireless router. I'm hedging my bests on the latter. I just got back from working on a computer at a friend's house and it was the same scenario as I stated before. I attached to his network and the GS tray icon popped up without any input on my part.

     
  • milkdudjenkins
    milkdudjenkins
    2011-01-04

    • status: open --> closed
     
  • milkdudjenkins
    milkdudjenkins
    2011-01-04

    I'm closing this post.

     
  • Jim Duchek
    Jim Duchek
    2011-01-04

    I'm still kind of curious what the problem is. It might be something I can work around. Does googsystray work if you start it from the command line? I'm planning to add availability of a bunch more debugging soon to try and figure these problems out.

     
  • milkdudjenkins
    milkdudjenkins
    2011-01-04

    • status: closed --> open
     
  • milkdudjenkins
    milkdudjenkins
    2011-01-04

    No. It doesn't work.

     
  • milkdudjenkins
    milkdudjenkins
    2011-01-04

    Thanks for the help Jim. It's my DSL/Wireless Router Combo from ATT. I manually put OpenDNS's servers in /etc/resolv.conf and the tray icon popped up immediately. There's updated firmware on the manufacture's website, but I don't think it's approved firmware by my service provider. Once again, thanks for a great piece of software. I got tired of having a browser open all the time for such a simple task.

     
  • Jim Duchek
    Jim Duchek
    2011-01-04

    Weird. Do you know what nameserver it's trying to use otherwise? I'd assume it sets the nameserver in /etc/resolv.conf to the router itself, but not sure if the router will tell you which nameserver it's using (my current one doesn't but I think my old one did).

     
  • milkdudjenkins
    milkdudjenkins
    2011-01-05

    Yes. They're listed on the router's info page and system log. I had a similar problem before where AntiVir Antivirus wouldn't update.