#1241 terminal postscript [enhanced]: DSC violations

5.0
closed-invalid
nobody
None
5
2013-05-20
2013-05-11
Helge Blischke
No

When plotting multiple pages (like "all.dem" in the demo directory) using the
postscript of enhanced postscript terminal, a PostScript error occurs when rendering the page generated by "enhanced_utf8.dem", probably because the generated
pages are not independent of each other.

The said page renders OK if generated as a single PS file.

Environment:
Mac OS X 5.8.3, gnuplot 4.6.3, compiled from the sources.

Discussion

  • Ethan Merritt
    Ethan Merritt
    2013-05-11

    • status: open --> open-invalid
     
  • Ethan Merritt
    Ethan Merritt
    2013-05-11

    Correct. PostScript does not support UTF-8, so trying to run UTF-8 demos using the postscript terminal will fail. That is a limitation of the PostScript language.

    There are some very complicated hacks that allow conversion of limited subsets of UTF-8 into a form usable by PostScript. See file .../term/PostScript/unicode_maps.README in the gnuplot distribution source. This method is IMHO unworkable in practice. If you need UTF-8 support, use some other terminal type for output.

     
  • Ethan Merritt
    Ethan Merritt
    2013-05-20

    • status: open-invalid --> closed-invalid