#32 make gtk 2.4 compatible

closed
nobody
None
5
2006-05-21
2006-04-22
Andy Schofield
No

Hi
The move from gtk 2.4 to 2.6 is killing me. Various
enterprise class linux distributions still use 2.4.
Could there be an option to switch off 2.6 dependent
features (is it just the About Dialogue that uses 2.6 -
I could live without that for example).
Thanks

Discussion

  • Andy Schofield
    Andy Schofield
    2006-04-22

    Logged In: YES
    user_id=24467

    Actually, simply removing 4 lines of code in gui.cc (where
    GtkAboutDialog is used) seems to work fine - allow me to
    compile with gtk 2.4.

     
  • Robert Sowada
    Robert Sowada
    2006-04-23

    Patch for gtk 2.4

     
  • Robert Sowada
    Robert Sowada
    2006-04-23

    Logged In: YES
    user_id=1134063

    Hi,
    I think it's just the about dialog, but I am not sure. I
    have attached a patch that should remove the about dialog
    feature. Can you test, if you can compile and run gnubiff
    with the patch applied?
    CU Robert :-)

     
  • Andy Schofield
    Andy Schofield
    2006-04-24

    Logged In: YES
    user_id=24467

    I applied the patch (to vanilla 2.2.0) and I can compile
    gnubiff and everything works as expected. Thank you - this
    is great.

     
  • Robert Sowada
    Robert Sowada
    2006-05-21

    • status: open --> closed
     
  • Robert Sowada
    Robert Sowada
    2006-05-21

    Logged In: YES
    user_id=1134063

    Gnubiff 2.2.1 has been released. There is a patch available
    in the patch section
    (http://sourceforge.net/tracker/index.php?func=detail&aid=1492581&group_id=94176&atid=606981).
    Therefore I will close this feature request.