Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#1 1.5 compilation fails, GTK+ incompat.?

closed-fixed
Edwin Young
None
5
2001-05-01
2001-03-12
Petter Sundlöf
No

I get the following errors when trying to compile
Gnofract 4D 1.5:

---
make[2]: Entering directory
`/home/odd/NL/gnofract4d-1.5/src'
c++ -DHAVE_CONFIG_H -I. -I. -I.. -I../intl
-I/usr/local/include -DNEED_GNOM
ESUPPORT_H -I/usr/local/lib/gnome-libs/include
-I/usr/local/include/glib-1.2 -I/
usr/local/lib/glib/include -I/usr/local/include/gtk-1.2
-I/usr/X11R6/include -I
/usr/local/include/gtk-1.2
-I/usr/local/include/glib-1.2 -I/usr/local/lib/glib/i
nclude -I/usr/X11R6/include -O3 -march=i686 -c
properties.cpp
properties.cpp: In function `void
create_propertybox_func_parameters_page(GtkWid
get *, GtkTooltips *, Gf4dFractal *, model_t *)':
properties.cpp:980: passing `const char *' as argument
3 of `gtk_object_set_data
(GtkObject *, const gchar *, void *)' discards qualifiers
make[2]: *** [properties.o] Error 1
make[2]: Leaving directory
`/home/odd/NL/gnofract4d-1.5/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/odd/NL/gnofract4d-1.5'
make: *** [all-recursive-am] Error 2
---

gtk-config --version
1.2.9

c++ --version
2.95.2

Discussion

  • Edwin Young
    Edwin Young
    2001-05-01

    • assigned_to: nobody --> edwin
    • status: open --> closed-fixed
     
  • Edwin Young
    Edwin Young
    2001-05-01

    Logged In: YES
    user_id=2194

    Have updated source package to compile correctly with gcc-
    2.95.3. Unfortunately this breaks egcs-x.x, but them's the
    breaks.