Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

Audiofile plays too fast

2009-08-23
2013-05-30
  • Hi,

    I recently discovered gnaural and really like it! Now I did try to compose a soundtrack which uses binaural beats plus spoken voice. The voice (=audio file) provides instructions for relaxation and later affirmations/suggestions.

    1) I now face the problem, that gnaural endless-loops the audio-file-voice, though I'd like it to stop after the file has finished. Is that possible?

    2) Also the audio-file is "speed-played", in about half of the actual time (i.e. a 20 sec file is played in 10 sec) - this makes the voice sound anything, but relaxing ;-) It is a .wav file which I recorded on my pocketpc, and it plays correctly in windows media player.

    (using gnaural 1.0.20090808 for windows)

    Thanks for advices!

     
    • gnaural
      gnaural
      2009-08-24

      Hi there, glad to hear you like Gnaural! To answer your questions in order:

      1)  The question as i read it is how to make your sound file end after one play rather than repeat for the duration of your schedule. That's super easy: just go to "Volume" view and at the exact time you'd like your sound file to be quiet, select the voice you are working-on, and double-click to add a data points to terminate the previous volume setting, zero the volume. then one more at the very end of the schedule with zero volume.

      Altogether that's three data points, and if you understand how precisely position and set these points using the right-click dialog, all three can be added in under 10 seconds. I say that only to point out that it's not a "hack", it's using the basic functionaltiy/approach of Gnaural, in which all voices are "endless repeat", and modulating their volume is the main means of control.

      2) My guess is that your WAV file was recorded at 22khz instead of the generic 44khz that PortAudio (the external library that Gnaural uses in order to be portable) expects. The work-around is to resample your WAV file. My suggestion would be to do it this way, using Audacity (http://audacity.sourceforge.net):
      - open your WAV file in Audacity
      - change the "Project Rate (Hz)" in the dropdown box at the lower left of the application to "44100"
      - under menu "File", select "Export", and in the dialog where you pick format, choose "WAV (Microsoft) signed 16-bit PCM"

      That should do it. If not, you could also try under menu "Tracks", select "Resample", select "44100", hit "Ok" -- but i just tested the above, and it worked fine. And yes, my 22khz file played double-speed, then played normally after this procedure -- but i did need to close Gnaural and restart it to completely clear-out the old WAV file.

       
      • Wow, thanks a lot

        That's some good tipps, exactly what I was looking for!
        Very nice

         
  • Ryan Randolph
    Ryan Randolph
    2010-09-11

    Is it possible to Export the Gnaural as a WAV and then add it into an editing program like Cubase or Audacity?  This may be easier for the editing purposes.  I am just wondering if the gnaural sound waves are preserved in this way.