Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#33 Unable to add map_type with admin tool.

closed-accepted
5
2004-01-07
2004-01-06
Ben Faga
No

Hello,

I've just installed CMAP_0.09. I am unable to submit
on the map_type_create page because it is not supplying
an accession_id. There isn't a box to input one (like
on the other creation pages).

Just curious, what is accession_id used for? It seems
like there are already keys to link the tables.

Also, (maybe this isn't a bug but) in the mysql table,
the default for map_type_id is 0. I used the default
to insert a map_type but when I tried to use the
map_type later, the map_type_id was read as false. If
there are no other issues involved, it would be simple
to set the default id values to 1 instead of 0.

Thanks,

Ben

Discussion

  • Logged In: YES
    user_id=469773

    Ben,

    I'm sorry, but you've hit a bug. I added the "accession_id"
    column to the map type table but missed fixing the admin form.
    D'oh! The accession ID is used as the public identifier for any
    database object that could be referenced by a URL. It's been my
    experience that it's best to avoid exposing your database primary
    keys as things can change, but accessions are never allowed to
    change. Keeping these two ideas separate really spares one
    much trouble when slinging data among different databases.

    Probably it would be best for us to take this off-list. I can send
    you patches that you can apply, or maybe I'll make a new tarball
    for you. I'm terribly sorry this bit you, but it can be resolved.

    ky

     
    • status: open --> open-accepted
     
  • Logged In: YES
    user_id=469773

    Ben,

    I just checked on this, and it looks OK. I'm not sure what to fix
    as the templates and code for creating and editing map types
    work well. I hate to question you on this, but are you sure
    there's a problem? (I just assumed right off that I had released a
    bug.)

    ky

     
  • Ben Faga
    Ben Faga
    2004-01-07

    • status: open-accepted --> closed-accepted
     
  • Ben Faga
    Ben Faga
    2004-01-07

    Logged In: YES
    user_id=903321

    Sorry, there was no bug. In upgrading from 0.08 to 0.09,
    the .08 template files were left behind. After removing
    those and changing the path of template_dir, it works fine.

    Ben