Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

Error: wrong ELF class: ELFCLASS32

Help
Ioeth
2006-12-11
2013-04-22
  • Ioeth
    Ioeth
    2006-12-11

    I'm getting an error when I try to run the notifier.  Output follows:

    [ioeth@rivendell gmail-notify]$ ./notifier.py
    Traceback (most recent call last):
      File "./notifier.py", line 9, in ?
        import pytrayicon
    ImportError: /etc/gmail-notify/pytrayicon.so: wrong ELF class: ELFCLASS32

    System configuration:
        * Fedora Core 6 2.6.18-1.2849.fc6 x86_64
        * HP dv8000 CTO
        * AMD Turion 64 ML-40
        * 2x1GB Corsair PC3200 ValueSelect RAM
        * 2x100GB Hitachi TravelStar 7200RPM HDD
        * Broadcom BCM4311 [AirForce 54g] 802.11a/b/g PCI Express Transceiver (rev 02)

    Any help is appreciated.  Thanks!

    --Ioeth

     
    • marcel
      marcel
      2006-12-26

      pytrayicon.so is a 32-bit binary. This won't work on x86_64 systems. I'm not sure where this module came from originally but I know it's included in the straw package. What you should do is get a x86_64 rpm of straw, extract the pytrayicon.py (with Midnight Commander for example) and put it in your gmail-notifier dir.
      I found an rpm at http://rpmforge.net/user/packages/straw/. It's packed for fc3 but it should work on any distro (it works on Gentoo).

      Hope that helps.

       
    • marcel
      marcel
      2006-12-26

      Oops. I actually meant you should extract pytrayicon.so, not pytrayicon.py!
      Sorry about that :-)

       
    • Georges A.K.
      Georges A.K.
      2007-04-10

      I had this problem too. After some trial and error, I found a version that worked for me. I put it here :
      http://rapidshare.com/files/25204742/pytrayicon.so

      Enjoy.