[BUG] URl seems to be wrong

Help
2007-10-31
2013-04-03
  • Hello!
    I tried your libgmailer, latest version, but I have the following error :

    <?php /** Start getting session from browser... **/ ?>
    <?php /** Completed getting session from server: GMAIL_HELP=EXPIRED; SID=DQAAAIsAAACE-T-VIdvX6gMPJYbLDWsoXRoMooDvAVrEDTIjzz2rDFat6vAjhMuSSz_--vF95ie22gTZz3ojcJjfc-YfSb-UJHdBKyIREBVHXIczrU-Ia4D4A5CzFzEt2i2Cx3HIthupaRYmwUU-nJmqwGUuw9jDAIn8-m_9fDY2IIOy9XaXoPuDpnVvNgdtV31WlP527Xc; LSID=DQAAAIwAAADlESfTCCDVxMceF_DUI6Wn4K4vW9eQwRwOAvJriiT33Xtn9MTZETZasBSg1yO7WezHx-mJcQXXHvPglvoKRsoaARwjRPZqxW9K2LYgc4jwbTFYGF1GUcyOkKS6mwPA9uAo_YpEe-BB_rzvY4c-OPWl0E6Y_59JQXHZRuPykO3WvCoW7Fkeui9mqoiC8sKLo_o; GAUSR=internuxswitzerland@gmail.com; TZ=0 **/ ?>
    <?php /** FAILED to read id_key from server. **/ ?>
    <?php /** Start fetching query: view=cl&search=contacts&pnl=a&fs=1 **/ ?>
    <?php /** Gmail response: HTTP/1.1 302 Moved Temporarily
    Set-Cookie: GMAIL_HELP=EXPIRED;Path=/;Expires=Mon, 01-Jan-1990 00:00:00 GMT
    Set-Cookie: GV=EXPIRED;Domain=mail.google.com;Path=/;Expires=Mon, 01-Jan-1990 00:00:00 GMT
    Set-Cookie: GV=EXPIRED;Domain=mail.google.com;Path=/mail;Expires=Mon, 01-Jan-1990 00:00:00 GMT
    Cache-control: no-cache, no-store
    Pragma: no-cache
    Location: https://www.google.com/accounts/ServiceLogin?service=mail&passive=true&rm=false&continue=https%3A%2F%2Fmail.google.com%2Fmail%2F%3Fview%3Dcl%26search%3Dcontacts%26pnl%3Da%26fs%3D1%26zx%3Dd8057k-hk5z1g%26ui%3Dhtml%26zy%3Dl&ltmpl=default&ltmplcache=2
    Content-Type: text/html; charset=UTF-8
    Transfer-Encoding: chunked
    Server: GFE/1.3
    Date: Wed, 31 Oct 2007 13:22:47 GMT

    <HTML>
    <HEAD>
    <TITLE>Moved Temporarily</TITLE>
    </HEAD>
    <BODY BGCOLOR="#FFFFFF" TEXT="#000000">
    <H1>Moved Temporarily</H1>
    The document has moved <A HREF="https://www.google.com/accounts/ServiceLogin?service=mail&amp;passive=true&amp;rm=false&amp;continue=https%3A%2F%2Fmail.google.com%2Fmail%2F%3Fview%3Dcl%26search%3Dcontacts%26pnl%3Da%26fs%3D1%26zx%3Dd8057k-hk5z1g%26ui%3Dhtml%26zy%3Dl&amp;ltmpl=default&amp;ltmplcache=2">here</A>.
    </BODY>
    </HTML>
    **/ ?>
    <?php /** Fetch completed. **/ ?>

    Seems it has moved, and this lib doesn't follow new link. Which var do I have to change ?

    I'm trying to grab all my contacts.

    Thanks in advance

     
    • I'm having the same issue.

       
    • I think it's because of the latest update to the gmail contact manager.  It was a big change.  I'm sure that affected stuff.

       
    • Ine fact, seems that it's the login step which fail (cf my post) [yep, I was first "nobody" of this post].

       
    • neerav
      neerav
      2007-11-14

      A MAJOR change in the signin code within the library means those pesky signin changes Google usually makes should not really have much of an effect anymore.  AND it makes the library 18KB lighter!

      http://gmail.sayni.net/forum/viewtopic.php?t=310

      --
      Neerav