Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#2 sig11 on Voodoo2 Hardware w/ Athlon

open
nobody
None
5
2000-01-27
2000-01-27
Anonymous
No

Sorry about the empty first report.

This bug concerns the Voodoo2 board running the latest Glide 2.53 on Athlon boards. Any app attempting to use the hardware returns a sig11. This includes the test3Dfx program.

A 'cat /proc/pci' does show the card.

There have been many posts on 3dfx.glide.linux to this effect. Here's a post/bug report from a savvy user I thought was worth pasting here:

----- BEGIN PASTE -----------

Buggered if I can make it work. Been trying off and on for almost two
months now and have yet to get anything but hangs or segfaults in
sst1InitRead32().

(gdb) bt
#0 sst1InitRead32 (addr=0x4) at util.c:522
#1 0x4003c31e in sst1InitMapBoardDirect (BoardNumber=4, resetSLI=2)
at sst1init.c:332
#2 0x4 in ?? ()
Cannot access memory at address 0x40.
(gdb) p addr
$1 = (FxU32 *) 0x40273214
(gdb) p *addr
Cannot access memory at address 0x40273214.
(gdb) p p6FenceVar
$2 = 1076310548

% LD_PRELOAD=cvg/lib/libglide2x.so /usr/local/glide/bin/test3Dfx
test00:
Clear screen to blue
2.53
Resolution: 640x480
Press A Key To Begin Test.
gd.0: GLIDE DEBUG LIBRARY
gd error (glide): _GlideInitEnvironment:
libglide2x.so expected Voodoo, none detected
gd.0: grSstQueryHardware() =>
0x0---------------------
Assertion Failed!: grSstQueryHardware( &hwconfig )
File:
test00.c

Line: 95

----END PASTE ------

Hope this helps...

We all appreciate the work you guys do.

chomsky@debian.org

Discussion

  • Logged In: NO

    I have Linux v2.4.2, XFree86 v4.0.2, Glide_V3-DRI-3.10, on
    Epox 7KXA (via KX133 chipset) with Athlon K7 Classic.

    I run the gears test program it works fine. (due to the fact
    that Glide-DRI is compiled in) (Yes my glx and dri modules
    load fine)

    I set "export MESA_GLX_FX=window" and gears fails with:
    gd error (glide): gd error (glide): grSstSelect:
    non-existent SST

    Where is the latest & greatest version of Glide for dri?

    This is not a hardware problem as I can boot into Linux
    v2.2.18/XFree 3.3.6 and all works fine.

     
  • Logged In: NO

    I have Linux v2.4.2, XFree86 v4.0.2, Glide_V3-DRI-3.10, on
    Epox 7KXA (via KX133 chipset) with Athlon K7 Classic with
    Voodoo3-AGP.

    I run the gears test program it works fine. (due to the fact
    that Glide-DRI is compiled in) (Yes my glx and dri modules
    load fine)

    I set "export MESA_GLX_FX=window" and gears fails with:
    gd error (glide): gd error (glide): grSstSelect:
    non-existent SST

    Where is the latest & greatest version of Glide for dri?

    This is not a hardware problem as I can boot into Linux
    v2.2.18/XFree 3.3.6 and all works fine.

     
  • Logged In: NO

    Update to my Voodoo3 problem:

    I got dri working by compiling and installing the Glide from
    source.

    It apears that a so library was missing with the bin package
    I had:

    libtexus.so.1.1

    Know idea if the libglide3.so.3.10 did fixed it or the
    missing lib above. But one thing is for certain is that the
    libglide3.so.3.10 is a larger file now:

    ls -l yields: 280315 Feb 26 23:32 libglide3.so.3.10
    sum yields: 37178 274
    file yields: ELF 32-bit LSB shared object, Intel 80386,
    version 1, not stripped

    Peter
    ps/ I am running Slackware v7.1