Thanks for the reply. I just tried putting the full path to libGLEW.a (tried both relative and absolute), and both times ld reported that it couldn't find the file.

Then I tried:

-l:libGLEW.a

And it didn't complain about not finding the library, but instead went back to the original "undefined reference" problem. Same thing when I put a full path instead of just the library file name.

What I don't understand is why it would link just fine against the .so version of the library, but not the .a version.

-Caleb

On Wed, Jul 28, 2010 at 8:44 AM, Nigel Stewart <nstewart@nvidia.com> wrote:
> On the GLEW website, it talks about how to do a static link under
> Windows, which works fine. However, I'm having trouble performing a
> static link under Linux.

Try this:

1. Compile application with -DGLEW_STATIC

2. Link static library explicitly
   -lGLEW -> relative/path/to/libGLEW.a

- Nigel

--
=============================================================
GPU Technology Conference (GTC 2010)
Sept. 20-23, 2010 | San Jose, CA | www.nvidia.com/gtc
Submissions: www.nvidia.com/object/call_for_submissions.html
Exhibits and Sponsorships: www.nvidia.com/object/exhibitors
=============================================================

-----------------------------------------------------------------------------------
This email message is for the sole use of the intended recipient(s) and may contain
confidential information.  Any unauthorized review, use, disclosure or distribution
is prohibited.  If you are not the intended recipient, please contact the sender by
reply email and destroy all copies of the original message.
-----------------------------------------------------------------------------------

------------------------------------------------------------------------------
The Palm PDK Hot Apps Program offers developers who use the
Plug-In Development Kit to bring their C/C++ apps to Palm for a share
of $1 Million in cash or HP Products. Visit us here for more details:
http://p.sf.net/sfu/dev2dev-palm
_______________________________________________
glew-users mailing list
glew-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/glew-users