Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

opening a project

Help
Randy
2007-07-12
2012-10-08
  • Randy
    Randy
    2007-07-12

    If I make a project and save it, then close it, and reopen it, the bitmaps do not display correctly. You see a box with an x in it, as if the bitmap can't be found. The bitmaps have not been moved. When the source code is generated and built, the following items are undefined:

    c:\glade 3.02\projects\test\src\main.c(16) : error C2065: 'PACKAGE_PREFIX' : undeclared identifier
    c:\glade 3.02\projects\test\src\main.c(16) : error C2099: initializer is not a constant
    c:\glade 3.02\projects\test\src\main.c(17) : error C2065: 'PACKAGE_DATA_DIR' : undeclared identifier
    c:\glade 3.02\projects\test\src\main.c(17) : error C2099: initializer is not a constant
    c:\glade 3.02\projects\test\src\main.c(18) : error C2065: 'PACKAGE_LOCALE_DIR' : undeclared identifier
    c:\glade 3.02\projects\test\src\main.c(18) : error C2099: initializer is not a constant
    c:\glade 3.02\projects\test\src\main.c(42) : error C2065: 'PACKAGE' : undeclared identifier

    I can get it to build and run by making the following changes:

    ifdef G_OS_WIN32

    gchar package_prefix = "";
    gchar
    package_data_dir ="";
    gchar *package_locale_dir = "";

    define PACKAGE 0

    endif

    But I'm not sure that is the correct thing to do. When the application is run, it doesn't display any of the bitmap images. Do you have any ideas ??

    Randy