#24 via82cxxx_audio and SMP

closed-works-for-me
Jeff Garzik
misc PCI (4)
5
2001-05-14
2001-04-26
Greg Hosler
No

Hi,

I have an onboard AC97 detected as:

kernel: Via 686a audio driver 1.1.14b
kernel: via82cxxx: Codec rate locked at 48Khz
kernel: ac97_codec: AC97 Audio codec, id:
0x5745:0x4301 (Unknown)
kernel: via82cxxx: IRQ fixup, 0x3C==0x12
kernel: via82cxxx: board #1 at 0x9C00, IRQ 18

My motherboard is a MSI-6321 (duap CPU).

This sound chip works fine under 2.2.x kernel, and
works under 2.4.3 single
processor kernel. but under the SMP kernel it really
doesn't work. it repeats
(forever) the 1st phrase/tone sent to the sound device.

for example, I was having problems in gnome (sound
sounded like a tapdancer),
so I decided to logout, kill esd, login as root, and
run sndconfig.

sndconfig sees the AC97 pci sound chip properly, but
when it goes to
play the sample sound, all I get is an infinite loop of
Linus repeating
"Hi, Hi, Hi, Hi, Hi, ..." instead of "Hi, I'm Linus,
and I ...".

this is the latest driver (1.1.14b)

any thoughts or suggestions. I am willing to put in
kprint statements, and
collect debugging info and/or assist in debugginbg
this.

thank yoiu, and regards,

-Greg Hosler

Discussion

  • Jeff Garzik
    Jeff Garzik
    2001-04-26

    • labels: --> misc PCI
    • assigned_to: nobody --> jgarzik
    • summary: via82cxxx_audio & SMP --> via82cxxx_audio & SMP
     
  • Jeff Garzik
    Jeff Garzik
    2001-05-12

    • summary: via82cxxx_audio & SMP --> via82cxxx_audio and SMP
     
  • Greg Hosler
    Greg Hosler
    2001-05-14

    Logged In: YES
    user_id=93778

    This problem was a BIOS bug. I upgraded my motherboard bios,
    and
    AC97 now properly workds under SMP.

    rgds,

    -Greg

     
  • Greg Hosler
    Greg Hosler
    2001-05-14

    • status: open --> closed-works-for-me