Problems pushing to sourceforge

Help
2010-08-12
2013-05-13
  • CarlBateman
    CarlBateman
    2010-08-12

    Help! This is driving me nuts.

    After finally cloning my local repository to sourceforge using the git bash command line I'm now trying to push the latest set of changes but with no luck.

    I believe I've correctly added an SSH key, but when I try to push I get the following message:

    C:\Program Files\Git\cmd\git.cmd push "origin" master
    The server's host key is not cached in the registry. You
    have no guarantee that the server is the computer you
    think it is.
    The server's rsa2 key fingerprint is:
    ssh-rsa 2048 xx:xx:xx:xx:xx:xx:xx:xx:xx:xx
    Connection abandoned.
    fatal: The remote end hung up unexpectedly

    Done

    When I test the connection I get the message

    Unable to open connection:
    Host does not exist

    I've tried various combinations but since I've no idea whether the problem is with SSH, Git, Git Extensions or SourceForge I'm just stabbing in the dark.

    TIA

     

  • Anonymous
    2010-11-06

    If you still get this problem, try to ssh to the server from git bash first manually,  when you get that error message normally it asks you do you want to connect anyway, then you can type yes git extensions gui does not let you input I think

     
  • Nathan T
    Nathan T
    2011-01-04

    More specifically running this in cygwin worked for me:
    ./plink.exe -agent PROJECTNAME.git.sourceforge.net

    It gives an error at the end but still adds the key.