Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

2.6.4 is broken

Developers
2009-01-06
2013-05-15
  • Darrell Long
    Darrell Long
    2009-01-06

    2.6.4 is broken on OS 10.5.6. I tried it on my MB Pro., no luck. Tried it on a fresh out of the box MacBook. Same problem:

    Process:         gimp-2.6 [39725]
    Path:            /tmp/skl/Gimp.app/Contents/Resources/bin/gimp-2.6
    Identifier:      gimp-2.6
    Version:         ??? (???)
    Code Type:       X86 (Native)
    Parent Process:  sh [39711]

    Date/Time:       2009-01-06 12:57:08.263 -0800
    OS Version:      Mac OS X 10.5.6 (9G55)
    Report Version:  6

    Exception Type:  EXC_BREAKPOINT (SIGTRAP)
    Exception Codes: 0x0000000000000002, 0x0000000000000000
    Crashed Thread:  0

    Dyld Error Message:
      Library not loaded: /usr/X11/lib/libXdamage.1.dylib
      Referenced from: /tmp/skl/Gimp.app/Contents/Resources/lib/libgtk-x11-2.0.0.dylib
      Reason: Incompatible library version: libgtk-x11-2.0.0.dylib requires version 3.0.0 or later, but libXdamage.1.dylib provides version 2.0.0

     
    • Darrell Long
      Darrell Long
      2009-01-06

      In other messages we learn that we must download Xquartz. How are the vast majority of people in the world going to know what?

      We learn on the Xquartz page that it must be reinstalled after every security update from Apple. That's really a problem since Apple is sending those out regularly.

      I think there needs to be a compelling reason to need a version of X11 other than what Apple is shipping. One would think that the GIMP developers want it used, but this mess guarantees that the vast majority of them who download it will get a mysterious crash and simply give up!

       
    • ... yes, somehow you're right. GIMP should run on a fresh installed 10.5.6 system as well as on a system with XQuartz 2.3.2 installed.

      I was so exited about the release of XQuartz 2.3.2 (it gives us support for graphic tablets, which many users are waiting for) that I installed it on my system. Boom, and with that an old (and mostly fixed) incompatibility problem hit me. The newly compiled binaries got linked against the XQuartz 2.3.2 libs (and therefor against this libXdamage compatibility version 3.0.0) although it should have been linked against the 10.5 SDK (which provides 2.0.0) As a consequence a "pure" 10.5.6 system won't run GIMP :-(

      Currently I'm trying to fix this and rebuild everything to link against 10.5 SDK.

      Sorry for the inconvenience.