GIMP 2.6.11 will not run under 10.6.8

Help
Snowshed
2011-11-15
2013-05-15
  • Snowshed
    Snowshed
    2011-11-15

    And yes, I did read the Important notes.rtf.    :-)

    I've tried a number of times to get Gimp to work, but nothing happens.

    With this last effort, I deleted the previous X11 and Gimp installs using AppCleaner.
    Installed X11 from my Snow Leopard disk.
    Ran X11, it reports 2.3.5 is installed.
    Ran Software update anyway, just to check.  No new X11, but I did get a new iTunes!   LOL
    Installed Gimp 2.6.11
    Run Gimp, nothing on the screen at all.

    X11 is displayed on Menu Bar if you click on the X11 icon in the dock.  In X11, if you click on the Applications Menu, 3 applications are listed, Terminal, Xman, and Xlogo.  Gimp is not listed there.  Is it supposed to be listed?

    If you click on the Gimp icon in the dock, nothing.  I do not have Gimp set to be kept in the dock.

    Gimp at least is running somewhere, as it is listed in the Force Quit Applications window.

    Where do we go from here to find out why Gimp is not running on my Mac?   :-)

    Checked for

     
  • AppCleaner won't help you uninstalling XQuartz nor Apple's X11, since XQuartz and Apple's X11 are in many system locations, where AppCleaner won't find them. Trashing /Applications/Utilities/X11.app only deletes the Launcher app.

    GIMP can be simply deleted by moving it to the Trash and delete the direcory "~/Library/Application Support/Gimp" in your home directory.

    If you had installed XQuartz from http://xquartz.macosforge.org/trac then this is the cause of your problems. Ask the guys there how you can completly deleted XQuartz and restore Apple's X11

    After you've removed XQuartz install Apple's X11 from the SL Installation DVD, run Software update, log out, log in, launch GIMP by double clicking on it, be happy.

    If it doesn't work, you've mixed up your system with XQuartz, so that Apple's X11 and any application which depends on Apple's X11 will get confused. Ask the guys on XQuartz Project about how to fix this.

    GIMP runs without any flaws on 10.6.8 with Apple's X11. Right out of the box. No need to install any X11 from anywhere on the net. Never.

    And as I've written in the Important notes.rtf. Be patient.

     
  • Snowshed
    Snowshed
    2011-11-15

    While I wait for a confirmation email for the user mailing lists…

    To be clear at my end, running the X-11 package from the Snow Leopard DVD does not completely overwrite and/or remove the Xquartz version?

    I have found this Apple X-11 vs. Xquartz situation to be totally confusing, but then I've only had a Mac about 3 years and have never really investigated the inner workings of OS X as I previously did with Windows/DOS and Atari operating systems.

     
  • please read this thread. It's only 5 days ago, since I've just answerd this….

    https://sourceforge.net/projects/gimponosx/forums/forum/761056/topic/4807890

    And, please, read the links you find there.

    For any further questions about XQuartz, ask the guys on the XQuartz Project. IMO, their decision to install XQuartz side by side with Apple's X1 is one of the worst decisions in developing software I've seen in the last few years. This will be no problem for developers, but IMO no user will understand, why he should have two complete sets of X11 programs, tools and binaries on his Mac. Again, ask them.

    AND: as they write on their website: "The XQuartz project is an open-source effort to develop a version…" So, it's a developer version of X11 and not meant to be for users. If you're a developer, well, do whatever you want, if you're a user do never install developer versions. It's that easy. (and I'm tired to explain this over and over again…)

     
  • Stephen Harvey
    Stephen Harvey
    2011-11-16

    With regard to xquartz  and x11 it has already been stated in this forum that they can both be installed on the same computer, they are 'app.' sensitive. Gimp needs apples "snow leopard' version has also been clearly stated. download from apple is not the same. and having tried 'software updates' it does not update from this facility automatically! (?)
      Clearly one should not expect an installation of x11 to over-write xquartz as they are 'different animals' (?)

     
  • Snowshed
    Snowshed
    2011-11-16

    That link is where I actually started from in trying to find out why things went haywire.  And also is why I put the comment in my original post in this thread about reading the important stuff.  :-)

    Following the links at http://xquartz.macosforge.org for the user list there led me to the X-11 users mailing list at Apple.  I've signed up with that list, and that was the confirmation email I mentio)ned earlier.  But I haven't had time to ask any questions yet, hopefully tomorrow (Wednesday).

    Following the links in the forum threads, you can find yourself here:  http://xquartz.macosforge.org/trac/wiki/X11-UsersFAQ  And that's way over my head.

    I can understand your frustration with this, but as I said, I found following web pages to get GIMP running to be confusing as H***.  But that should be another topic.

     
  • Snowshed
    Snowshed
    2011-11-18

    I don't know where the problem lies, but I'm narrowing it down.  And it's not Gimp and X11.

    I never got a satisfactory answer to my question of how to completely remove X11 and XQuartz, so I took a different troubleshooting route.

    I added a new partition to my internal drive, and installed a fresh copy of Snow Leopard.  Then, installed Gimp from the .dmg package.

    Gimp ran!

    A side note, at this point, the internal drive/partitions displayed on the new desktop.

    Next, I reinstalled Snow Leopard in my normal boot partition.  Gimp will not run.  It doesn't even cause X11 to automatically run.

    To confirm Gimp would still run on the other start up partition, I booted to that partition.  Gimp ran.

    But now, the internal drive/partitions did not display.  Something changed the Finder preferences.

    There still has to be some kind of conflict in my normal partition, and now I'm working on a plan to solve that.

    I also tried Inkscape, another X11 app, and it runs in the new partition, but not the normal one.