Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

2.8.2 very slow to launch on OS X 10.6.8

Help
pitpat
2012-09-18
2013-05-15
  • pitpat
    pitpat
    2012-09-18

    Hi I just change from the X 11 version of GIMP to the new non x-11 version.

    Its very slow to launch. The Splash Screen appears and sort of hangs with the message "Starting Extensions extensions-script-fu". It takes around 65 seconds for GIMP to then boot. This happens every time.
    Console has a message that seems to be linked to this delay:

    Cannot spawn a message bus without a machine-id: Unable to load /var/lib/dbus/machine-id or /etc/machine-id: Failed to open file '/var/lib/dbus/machine-id': No such file or directory
    

    I am running OS X 2.6.8  and Gimp 2.8.2 

     
  • pitpat
    pitpat
    2012-09-20

    Anyone ???

     
  • asiga
    asiga
    2012-09-24

    I'm running it on a Macbook Air with 10.6.8, and Gimp 2.8.2 starts as fast as previous versions (if we discount the delay needed to start X11 in the past). I can see this same message you said in the error Console, but this error doesn't slow down the startup of Gimp. I'd say it starts quickly (about 5 or 6 seconds to be exact).

     
  • asiga
    asiga
    2012-09-24

    Just a clarification: I can't affirm that this error doesn't slow down Gimp on some machines, I just wanted to say it doesn't slow down my Macbook Air.

     
  • pitpat
    pitpat
    2012-09-24

    Hi asiga, thanks for taking the time to share that info. At least I know the console message is probably a red herring. Thanks.

     
  • pitpat
    pitpat
    2012-09-24

    I forgot to say I'm on an iMac.

     
  • mechatroniker
    mechatroniker
    2012-09-26

    Hi Pitpat, I can confirm the slow startup.
    I am also working on an iMac (late 2006, C2D) with Snow Leopard. Until now, I tried the following:
    * cleared all leftovers (~/Library/…) of the X11 version, installed native version => same behaviour
    * cleared all leftovers of the native version, tried the other build from Gimp.org (without SKLs extras) => same behavior

    What I did notice is that if I start Gimp alone, it always hangs on the splash screen with said "extension-script-fu" message. But sometimes it's different, if I drop an image on the dock link; then it hangs on "searching documents". The splash screen stais in foreground of all apps, and I see the spinning beachball, but no abnormal CPU load or hdd activity.

    I tried starting Gimp from the terminal but could not see any unusual messages.

     
  • mechatroniker
    mechatroniker
    2012-09-26

    Just tried SKLs build on a MacBook Pro late 2006, Snow Leopard quite fresh install (with Apple's X11 installed), no previous Gimp install, all the latest updates: no delay whatsoever.
    So it looks like the phenomenon is model dependent; I will try native Gimp on my good old white MacBook late 2006 (also Snow Leopard) this evening.

     
  • mechatroniker
    mechatroniker
    2012-09-26

    Two more things:
    * Uninstalling XQuartz on the iMac did not help; startup still slow.
    * Deleting Gimp-2.8-XQuartz from my MacBook (Snow Leopard, C2D with Intel GMA) and installing native Gimp (without deleting the configuration files) works like a charm; I cannot see an unusual delay.

    Anyone got ideas what I could check on the iMac?

     
  • pitpat
    pitpat
    2012-09-26

    Hi mechatroniker. Its great to hear I'm not alone.
    I'm on a late 2009 iMac.

    I was just about to write that the one thing I noticed is that the help system is similarly slow. It takes about a minute for the Help page to load in my browser.

    I then launched the GIMP to double check and it opened up with out delay! And I also tried the Help and it loaded up with out delay too. So there may be a link between them.

    I have no idea what has fixed this. It might be an apple "Security Update 2012-004" but I downloaded that on six days ago -I can't remember when I last opened the GIMP - so I'm not entirely convinced that's the reason for the fix but its worth a try if you don't already have it.

    I'll try and think what else I may have installed.

     
  • mechatroniker
    mechatroniker
    2012-09-27

    I do not think, that the issue is related to the security update.
    The behavior on my work iMac was the same before installing the latest updates from Apple. Native Gimp was installed before the security update and was as slow on startup as it still is.
    Maybe the help files need to be initialized once or something like that, but that would not explain my experiences on the two MacBooks. I'll try opening the help later on and let you know.

     
  • pitpat
    pitpat
    2012-09-27

    I have it.
    The delay is caused by a LAN cable that's connected to my iMac but not to the internet and also having the WiFi off at the same time.

    It would appear that the GIMP tries to make some kind of connection via the internet if it finds a working LAN or WiFi connection. When the WiFi is off it tries via the LAN port but as mine is not connected to the net it waits the 60secs and then times out and gives up, hence the delay.

    Usually I wouldn't have WIFi on but I would have my LAN connected when I use the GIMP. But for my previous post here I had the WiFi on to make my post and then launched the GIMP with the WIFi on there was no delay.

    With the WiFi off but LAN cable connected there is the delay, but as soon as I unplug the LAN the GIMP opens up.

     
  • mechatroniker
    mechatroniker
    2012-09-27

    Now as you say it… ;-)
    My work iMac is connected to the ethernet, no WiFi, but internet acces is only possible via an authenticated proxy connection. => slow startup
    Ethernet cable detached => works. But of course the workflow then is suboptimal.

    I found out that for an undelayed startup, you can also just deactivate all network devices in system settings (using the small gear symbol) and click "Apply" instead of unplugging the ethernet cable.

     
  • pitpat
    pitpat
    2012-09-27

    Great, that's a handy workaround. I wasn't keen on having to plug the LAN cable in an out repeatedly.

    I tried to figure out what the GIMP is connecting to the net for. I tried to capture a few packets with wireshark but I can't actually see anything being sent! But then again I'm far from proficient at wireshark and network protocols.

    I also tried adding it to the blacklist of an outbound firewall but that didn't help.

    I wonder what the GIMP is actually doing trying to connect -is there some way it could be disabled or is it a bug?  I can't see anything in the preferences about switching updates on/off or anything else that might be relevant.

    Perhaps its the script-fu extension that's trying to connect (whatever that is)? 

     
  • pitpat
    pitpat
    2012-10-26

    Here's a refinement of mechatroniker's tip that makes toggling the LAN connection on and off easier. It simply just making a new Location with the Ethernet location permanently disabled. But its much quicker to toggle than having to open System Prefs every time.

    Open System Pref/Network and in the Location bar select "Edit locations".
    Click on the + and Name your new location along the lines of "No Connection for GIMP"

    Click Done and then click Apply. Make sure you click apply!

    Then as previously described select the "Ethernet" and click on the little cog icon and select "Make service inactive". Make sure you click apply.

    I did the same also for "Air Port" too.
    Now select your original Location probably "Automatic" and click Apply

    Now when you want to toggle the connections on and off. On the Menu bar click on the Apple icon. from the drop down menu hover over Location and select your new "No Connection Gimp" location and its done.