#10 Eyedropper won't select color

closed-fixed
nobody
None
5
2010-01-05
2009-07-06
Anonymous
No

Hi there. I have a MacBook Pro (newly purchased). i downloaded the Gimp x11. The eyedropper will not select a color. When I choose the eyedropper, then click on a color it reverts back to black (or html color #000003). Any thoughts on how to fix? Why is it doing this?
Thanks,
LittleMeTG

Discussion

  • sorry, but I can't reproduce this.

     
    • status: open --> pending
     
    • status: pending --> open
     
  • I also have a new 17" MacBook Pro. I have the same issue with the eyedropper. It's a terrible thing to be missing. Help please!

    HiDraft

     
  • ~suv
    ~suv
    2009-09-22

    Does this help?
    "can you try to move your personal gimp settings directory out of the way as if you have never used Gimp before?" <http://groups.google.com/group/comp.graphics.apps.gimp/browse_thread/thread/f19fb0d56059dfcb>

    i.e. quit GIMP, browse to '~/Library/Application Support' and rename 'Gimp' to 'Gimp-tmp', then restart GIMP and try the color-picker tool again... If it didn't help, trash the newly created '~/Library/Application Support/Gimp' and rename the previous 'Gimp-tmp' to Gimp to restore your previous settings.

    And don't forget to read the manual page <http://manual.gimp.org/en/gimp-tool-color-picker.html> - as default GIMP picks the color of the active layer, but you can change that in the 'Color Picker Options' dialog.

    hth, ~suv

     
    • status: open --> closed-works-for-me
     
  • sorry folks, I've mixed something up when first reading this bug report. The exdropper from Tools -> Eyedroper works as expected but the one from within some other dialogs (e.g. exchange colors) won't work.

    The reason is that X11 on Mac OS X has not root window. And this root window is used by GIMP to make an internal screenshot and pick up the color from there.

    I'll test some patches to see if I can get a workaround.

     
    • status: closed-works-for-me --> open
     
  • ... fixed in 2.6.8p1 for Snow Leopard and 2.6.8 for Leopard

     
    • status: open --> closed-fixed