Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

App Engine support + GWT 2.0

hiyarnuri
2009-12-25
2013-04-25
  • hiyarnuri
    hiyarnuri
    2009-12-25

    Current version of app engine support was added in May 2009 and Gilead site says that it ise  not for production. I would like to know what is the current situation with GAE adapter, does it work fine and could be used for production applications? Does it work with GWT2.0 and AppEngine-Java 1.3 JPA. I currently use the Gilead hibernate adapter with GWT2.0 + JPA + Hibernate + MySQL with success and planning to move to App Engine
    Thanks!

     
  • Hello,

    I have not tested the Adapter for GAE with GWT 2.0 and latest appengine, but I will have to do it before publishing the new release.

    Note that as far as I know, GWT 2.0 provides a new serialization process to handle properly AppEngine DataNucleus entities.

    Gilead will thus focus on providing DataNucleus classes emulation for GWT (Blob, Key and so on), instead of serialization process.

    Regards

    Bruno

     
  • hiyarnuri
    hiyarnuri
    2010-01-04

    Hi Bruno,

    Thanks for the reply, so it means there is support for GWT-RPC for App Engine JDO, and JPA classes. You say that corresponding classes for Blob, Key etc  is missing in GWT 2.0. So if we would use them now (without the new version of Gilead) serialization would break, am I  correctly interpreting this?

     
  • Youngster
    Youngster
    2010-01-19

    Hi,

    Any update on this topic? I think you did publish the new release.
    Should Adapter for GAE be working with GWT 2.0 now?
    Anyone using it in this configuration?

    Thanks a lot!

     
  • Sridher
    Sridher
    2010-01-28

    Hi,

    The adapter working fine with gwt1.7.1 with GAE1.3.

    is there any progress in GWT2.0 Adapter

    Thanks

     

  • Anonymous
    2010-11-05

    I am trying to use the Adapter with GWT 2.1, GAE 1.3.8 (which I think are the current versions).  I get the following error for which I cannot find a workaround….

    Note: This may not be the fault of the adapter, but I noticed the code near the top of the stack trace…

    javax.servlet.ServletContext log: commitmentServiceImpl: An IncompatibleRemoteServiceException was thrown while processing this call.
    com.google.gwt.user.client.rpc.IncompatibleRemoteServiceException: This application is out of date, please click the refresh button on your browser. ( Expecting version 5 from client, got 6. )
    at com.google.gwt.user.server.rpc.impl.ServerSerializationStreamReaderCopy_GWT16.prepareToRead(ServerSerializationStreamReaderCopy_GWT16.java:419)
    at com.google.gwt.user.server.rpc.RPCCopy_GWT16.decodeRequest(RPCCopy_GWT16.java:234)
    at net.sf.gilead.adapter4appengine.EngineRemoteService.processCall(EngineRemoteService.java:60)
    …..
    The adapter quickly solved the problem I had with dealing with GAE's Key class, so it would be awesome if it worked on 2.1/1.3.8 (or if there was some other solution to my IncompatibleRemoteServiceException).

    Thanks so much!
    RB

     

  • Anonymous
    2010-11-05

    No need to address my question - I shifted to another download that resolved my issues.