Character set used in tag text - not UTF-8

2013-09-17
2013-09-22
  • Matthew Geier
    Matthew Geier
    2013-09-17

    Is there a way for 'force' geotag to use UTF-8 ?
    eg
    exiv2 reports from one of my images -

    Iptc.Application2.LocationName String 23 Bratislava - Petržalka
    Iptc.Application2.SubLocation String 31 Bratislava-Petr�alka railway st

    Both should be more or less the same. The LocationName I 'corrected' with gthumb and is in UTF-8.
    I'm not sure what character set the location written by geotag was. (I assume Windows Western Europe).

    It would make my life a lot easier if all those foreign place names that geotag fetches for me were in the correct character set.

    Note i'm using Java7 web start on Linux. (Ubuntu)

     
  • Hi Matthew,

    This is an exiftool problem, but I might have a solution for you. Try this:
    In Geotag open File -> Settings -> External programs -> Exiftool -> Additional Exiftool arguments
    Then at the bottom type in:

    -charset iptc=UTF8

    (note that there is no dash in UTF8 here) and click OK.
    Then save the image location for your image. I got something like

    Iptc.Application2.LocationName String 32 Železničná Stanica Petržalka
    Iptc.Application2.SubLocation String 32 Železničná Stanica Petržalka
    Iptc.Application2.ProvinceState String 13 Bratislavský

    … and that looks OK to me… hope that helps

    Andreas

     
    • Matthew Geier
      Matthew Geier
      2013-09-22

      That did it. I'm happy now.

      Our travels have taken us to northern Germany now, where the place names don't have so many accented letters, but the ones that geotag does get from the place names server are now written in UTF-8 and consistent with my other software.