Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

Importing Shapefiles on Linux

2012-07-09
2012-12-18
  • Hi, I have a linux distro with Oracle 11gR2 sqdevleoper 3.1.07 and the latest georaptor fie (dd july 9 2012). When I use the shapefile import function on this platform it says "no such file or directory" when I add the file that I can choose. I already tried to give all read+write privileges to the file, tried to create a oracle directory object with read and write access to the user, tried DBA user, but nothing helps. I cannot import the shapefiles on this platform. Last week I did the same using a windows client with sqldeveloper+georaptor, and then it works? Any one who can help me out?

     
  • Simon Greener
    Simon Greener
    2012-08-17

    Hoog-it,

    I'm sorry that I didn't see this till now.

    I don't have a linux distro to check this problem. I will have a look at the code base to see if I can see why this is occurring. A new release called 3.1 is about to go out. You can access it via the Early Access URL on the georaptor site.

    regards
    Simon

     
  • Pieter Minnaar
    Pieter Minnaar
    2012-08-19

    Hi,

    We are looking at the problem - it is probably because of case sensitive names in linux.

    In the meantime could you try to place the files in an uppercase directory and also make the shape and dbf files uppercase?
    The file extensions (shp and dbf) should be lowercase.

    Regards,
    Pieter