#100 BG2 - Jaheira doesn't notice door is open

GemRB Main Engine
closed-fixed
Laszlo Toth
GamePlay (136)
6
2008-09-17
2008-02-17
Suggs bill
No

After getting the jail key and opening the door to Jaheira's cell she will not enter the party as she still believes to cell door to be closed and locked.

Discussion

  • Suggs bill
    Suggs bill
    2008-02-17

    • labels: --> GamePlay
    • milestone: --> GemRB Main Engine
     
  • Laszlo Toth
    Laszlo Toth
    2008-02-21

    • assigned_to: nobody --> avenger_teambg
    • status: open --> closed-works-for-me
     
  • Laszlo Toth
    Laszlo Toth
    2008-02-21

    Logged In: YES
    user_id=885460
    Originator: NO

    This also works for me. Weird...

     
  • Suggs bill
    Suggs bill
    2008-02-21

    Logged In: YES
    user_id=736400
    Originator: YES

    This one seems to be intermittent. I've had the same problem getting Minsc out of his cell in one session but in the next he walks out with no problems. In both sessions I was unable to get Jaheria out of her cell, however in a third play around she walked straight out...

    I'll test again this weekend with the latest svn code.

     
  • Suggs bill
    Suggs bill
    2008-02-24

     
    Attachments
  • Suggs bill
    Suggs bill
    2008-02-24

    Logged In: YES
    user_id=736400
    Originator: YES

    In the attached screenshot section you can see where I've unlocked the door to Jaheria's cell. You can also see where her circle is still cyan where she's not joined the party. This was my fourth attempt at talking to her to get her to come out of the cell.

    This was using svn revision 5092. Compiled with gcc 4.2.3 as packaged in debian unstable. Built on an amd64 box.
    File Added: free_jaheira.jpeg

     
  • Suggs bill
    Suggs bill
    2008-02-24

    • summary: BG2 - Jaheira doens't notice door is open --> BG2 - Jaheira doesn't notice door is open
    • status: closed-works-for-me --> open-works-for-me
     
  • Laszlo Toth
    Laszlo Toth
    2008-09-17

    • priority: 5 --> 6
     
  • Laszlo Toth
    Laszlo Toth
    2008-09-17

    OK, this was caused by saving the actors twice (once with are once with gam). You will experience this bug with all your saved games, you will need to start a new one (then save, reload) to check if this is still there.
    You can confirm buggy saves by ctrl-j over jaheira (or minsc) if they die, but another copy stands around, then that save is corrupted.

    (Works for me was because i immediately went to Jaheira and Minsc, but the bug happens only when you reload a saved game).

     
  • Laszlo Toth
    Laszlo Toth
    2008-09-17

    • status: open-works-for-me --> closed-fixed