Plugin not working on XFCE

  • Queseuq

    Hi, I'm using a ubuntu variant that uses XFCE and the plugin doesn't seem to fully work.  The toolbar not appearing and code compleation not working are two things I have noticed.  New menu items do appear however.  Is this because I am using XFCE or is something else to blame?

  • Hi,

    I'm not sure whether the plugin uses some Gnome libraries that aren't available on Xfce…

    Can you run gedit from a console and post the debug output here? I can tell you more then.



  • Anonymous

    Hi, here is the output when I start-up gedit with the plug-in disabled, enable the plug-in and then click 'Configure Plug-in'. I looked in /usr/share/gedit-2/plugins/GeditLaTeXPlugin and only the icons folder was present.

        2010-01-03 14:21:56,024 DEBUG resources - Initializing resource locating
        2010-01-03 14:21:56,263 WARNING resources - File not found: /usr/share/gedit-2/plugins/GeditLaTeXPlugin/glade/
        2010-01-03 14:21:56,272 WARNING resources - File not found: /usr/share/gedit-2/plugins/GeditLaTeXPlugin/glade/
        2010-01-03 14:21:56,341 DEBUG Preferences - <value key='BibtexExtensions'> not found
        2010-01-03 14:21:56,383 DEBUG JobManager - Created JobManager instance 174768108
        2010-01-03 14:21:56,397 DEBUG GeditLaTeXPlugin - activate
        2010-01-03 14:21:56,398 DEBUG WindowContext - init
        2010-01-03 14:21:56,605 DEBUG GeditTabDecorator - No file loaded
        2010-01-03 14:21:56,606 DEBUG GeditWindowDecorator - ------- ADJUST: None
        2010-01-03 14:21:56,614 DEBUG GeditWindowDecorator - No window-scope views for this extension
        2010-01-03 14:21:56,620 DEBUG GeditWindowDecorator - _set_selected_bottom_view: 0
        2010-01-03 14:21:56,620 DEBUG GeditWindowDecorator - _set_selected_side_view: 0
        2010-01-03 14:21:56,621 DEBUG GeditWindowDecorator - _init_tab_decorators: initialized 1 decorators
        2010-01-03 14:22:05,463 DEBUG Preferences - <value key='SpellCheckDictionary'> not found
        Traceback (most recent call last):
          File "/home/nick/.gnome2/gedit/plugins/GeditLaTeXPlugin/src/", line 104, in create_configure_dialog
            return PreferencesDialog().dialog
          File "/home/nick/.gnome2/gedit/plugins/GeditLaTeXPlugin/src/preferences/", line 538, in dialog
            check_hide_box.set_active(self._preferences.get_bool("HideBoxWarnings", False))
        AttributeError: 'NoneType' object has no attribute 'set_active'
        ** (gedit:3387): CRITICAL **: gedit_plugins_engine_configure_plugin: assertion `conf_dlg != NULL' failed

    Thanks for the help.

  • Which versions of the plugin, gtk and glade do you have installed?


  • Anonymous

    I've got it working now thanks.  Think I hadn't properly removed rc1 from Synaptic before installing rc3 from sourceforge.  Thanks for the help.